Problem about Pocketsphinx!


#1

I usually use Pocketsphinx, but on https://cmusphinx.github.io/, it does not matter, but when I install the tutorial and run on the Matrix voice it fails underneath. I do not know Must add sphinx library or not. Help you, thank you much!

[NAME] [DEFLT] [VALUE]
-agc none none
-agcthresh 2.0 2.000000e+00
-allphone
-allphone_ci no yes
-alpha 0.97 9.700000e-01
-ascale 20.0 2.000000e+01
-aw 1 1
-backtrace no no
-beam 1e-48 1.000000e-48
-bestpath yes yes
-bestpathlw 9.5 9.500000e+00
-ceplen 13 13
-cmn current live
-cmninit 8.0 40,3,-1
-compallsen no no
-debug 0
-dict assets/6706.dic
-dictcase no no
-dither no no
-doublebw no no
-ds 1 1
-fdict
-feat 1s_c_d_dd 1s_c_d_dd
-featparams
-fillprob 1e-8 1.0000


-topn_beam 0 0
-toprule
-transform legacy legacy
-unit_area yes yes
-upperf 6855.4976 6.855498e+03
-uw 1.0 1.000000e+00
-vad_postspeech 50 50
-vad_prespeech 20 20
-vad_startspeech 10 10
-vad_threshold 2.0 3.000000e+00
-var
-varfloor 0.0001 1.000000e-04
-varnorm no no
-verbose no no
-warp_params
-warp_type inverse_linear inverse_linear
-wbeam 7e-29 7.000000e-29
-wip 0.65 6.500000e-01
-wlen 0.025625 2.562500e-02

FATAL: “cmn.c”, line 126: Unknown CMN type ‘live’…


#2

Hi,

We have a compiled package on our repositories, maybe you can try it:


#3

I updated to last version and merge last pull request.


#4

sorry, when you install “sudo apt install matrixio-malos”, it says "matrixio-malos is already the newest version (0.2.2).
You might want to run ‘apt --fix-broken install’ to correct these.
Những gói có liên kết chưa có kết hợp:
libmatrixio-protos: Depends: matrixio-protobuf but it is not going to be installed
matrixio-malos: Depends: matrixio-protobuf but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages.
When I “sudo apt --fix - broken install” it also reported error, I have looked at the whole night without resolving dc.hope you help. Thank you!


#5

Please give me more information about your system, for example Raspbian version, and package list, maybe dpkg -l | grep matrix and dpkg -l | grep -i sphinx ty


#6

Sorry, I’m too busy to answer you. I’m using the Raspbian GNU / Linux 9.3 (stretch) version. I do not know whether to install any tools or packages before Malos or not. The level you give yourself is using javascrip right? I just know c / c ++. thank you so much!


#7

For only you work with C++ layer, first please install MALOS and malos-wakeword for your base libraries (it will be install pocketsphinx and sphinxbase libraries):

sudo apt-get remove matrix-creator-* libmatrix* --purge
curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
sudo apt-get update
sudo apt-get upgrade
sudo apt install matrixio-malos
reboot

Then please use the examples in the next source code:

NOTE: please omit dependencies and build sections on it, are outdated

The main example for you target is next:


#8

thank you, i will test you … happy day!