Android Things demo: 0 sensor values

Hi Guys,

I’m trying to get the android things demo going.

Found it here:

Contribute to matrix-creator-android-things development by creating an account on GitHub.

Unfortunately, I don’t seem to be able to get anything to work.

When I run the application from AndroidStudio I get a bunch of:
D/MainActivity: UV: 0.0 AL: 0.0 PR: 0.0 TP: 0.0 HM: 0.0 TP: 0.0 YW: 0.0 PT: 0.0 RL: 0.0

And there is no Everloop LED activity. I tried modifying the app to change the LED values by hand, but that didn’t work either.

all the normal demos for sensors and everloop do appear to work in raspberian, however initially I was getting 0 sensor values in there as well… to fix, I followed instructions on this page and it worked.

However, I can’t do that fix on Android Things, so I’m at a bit of a loss.

For my application, I will also need to access the microphone array, which I have not tested yet.

Any help would be appreciated.

thanks!

-thomas

I remember having this problem. I wrote something pretty extensive about what I did to get this working, just do not have time to find it right now. I am pretty sure it had something like “zero sensor values” in the title.

Is it the one I quoted in my original post? If so, unless I’m mistaken, that solution will only work for raspbian. I need it for Android Things. I am new to Android Things however, so maybe there’s a way to do it there too?

Ahh, it might have been then. I do not think I have tried using Android of Things. Does it make it possible to interface with it from Android devices or something?

Hello, I’m part of the Matrix Creator team. We’re sorry for the confusion, so we have released a first [documentation] (https://github.com/matrix-io/matrix-creator-android-things/blob/master/README.md) (provisional) that solves the initialization in Google Things.

We also ask you to help us by voting to release low level documentation in this link to continue developing this version.

Thank you very much for using the Matrix Creator.

1 Like

Thanks @Hpsaturn. This will definitely help get me going!

For my project, I am needing to use the mic array. Do you have any idea of the timeline for getting this running?

Thanks again!!

-thomas

We are just working on it. Maybe for this week we have it working!

Any update here? :slight_smile: I attempted to get the Matrix Creator’s mic array working with Android Things (using mic array branch on github), but couldn’t figure out if it was actually working… I couldn’t figure out how to get it to register as a mic in my app, either.