Cannot pass hardware tests and no microphone input

Hi,

I’m unable to get any input on my Matrix Voice on RPI3. I followed these instructions: https://github.com/matrix-io/google-assistant-matrixio

If I try the google assistant, I got this error:

[5088:5120:ERROR:mic_failure_detector.cc(140)] [assistant] Channel 1 has failed. Powers -inf and -inf

arecord seems to see my card:

pi@ullr:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: SOUND [MATRIXIO SOUND], device 0: matrixio.mic.0 snd-soc-dummy-dai-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

If I record with arecord (as instructed in the readme), the test.wav only produces a low static sound.

I tried to follow the Hardware tests, but there seems to be issues:

matrix-init.bash

pi@ullr:~$ sudo /usr/share/matrixlabs/matrixio-devices/matrix-init.bash
MATRIX device has not been detected
**** Could not program FPGA
MATRIX device has not been detected

It’s not normal that “Matrix device has not been detected”, right ? What can I do to make it detected ?

fpga_info

pi@ullr:~$ sudo /usr/share/matrixlabs/matrixio-devices/fpga_info
INFO: [/dev/matrixio_regmap] was opened
MATRIX device has not been detected
FPGA IDENTIFY = 6239
FPGA VERSION = 10bd8

fpga-program

pi@ullr:~ cd /usr/share/matrixlabs/matrixio-devices/ pi@ullr:/usr/share/matrixlabs/matrixio-devices sudo ./fpga-program.bash
MATRIX device has not been detected
**** Could not program FPGA

gpio status

pi@ullr:/usr/share/matrixlabs/matrixio-devices$ sudo cat /sys/kernel/debug/gpio
gpiochip0: GPIOs 0-53, parent: platform/3f200000.gpio, pinctrl-bcm2835:
gpio-18 ( |sysfs ) out hi
gpio-26 ( |sysfs ) out hi
gpio-35 ( |? ) in hi
gpio-47 ( |? ) out lo

gpiochip1: GPIOs 496-511, parent: spi/spi0.0, matrixio-gpio, can sleep:

How can I fix the GPIO to match those of the doc ?

Every package on my machine has been upgraded.

I’m really at a loss here :tired_face:

Thanks

Another thing I guess is weird is that mic_channelX do not exist. A lot of examples are using it, but I don’t see them in arecord -l and cannot use them.

root@ullr:~# arecord --device=mic_channel1 -r 16000 -c 1 -f S16_LE test.wav
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM mic_channel1
arecord: main:807: audio open error: No such file or directory

Hi @wichtounet,

Did you tried the Hardware test starting form scratch? If no, please do and let me know how it goes. We can go steps by step to find what could be happening.

-Yoel

Hi @yoelrc88,

What do you mean from scratch ? I followed all the steps from MATRIX Creator/Voice Hardware Test
You can see the results to all the commands in my first post. Starting with matrix-init.bash

What else can I do ?

Thanks

Sorry, by scratch I meant starting from zero flashing the sdcard with a new Raspbian image.

No, I didn’t start from scratch. But there was barely anything installed on this pi before.

It took me several hours to install all the Matrix Voice/Home Assistant already. And I don’t have any spare SD card. I won’t have time any time soon to do it again.

Isn’t there any way to debug it without restarting from scratch ?

Sure, can you share the output of :

sudo dpkg -l | grep matrix
lsmod -l | grep matrix

Thanks

Here it is:

dpkg:

pi@ullr:~$ sudo dpkg -l | grep matrix
ii libmatrixio-creator-hal:armhf 0.3.2 armhf Hardware Abstraction Layer for MATRIX.
ii matrixio-creator-init 0.4.8 armhf Install scripts that can program the MATRIX Creator FPGA and SAM3 IMU.
ii matrixio-kernel-modules 0.1-3 armhf Install kernel modules for MATRIX devices.
ii matrixio-openocd 1.0.1 armhf Open on-chip JTAG debug solution for ARM and MIPS systems
ii matrixio-xc3sprog 1.1.1 armhf Spartan3, XCF and CPLD JTAG programmer and other utilities

lsmod (there is no such as lsmod -l on this RPi)

pi@ullr:~$ lsmod | grep matrix
matrixio_pcm 267105 1
matrixio_codec 5030 1
snd_soc_core 179915 2 matrixio_pcm,matrixio_codec
matrixio_uart 5974 0
matrixio_env 2836 0
matrixio_imu 2946 0
industrialio 62929 2 matrixio_imu,matrixio_env
matrixio_gpio 2726 0
matrixio_everloop 2406 0
matrixio_regmap 50813 0
matrixio_core 4501 4 matrixio_regmap,matrixio_pcm,matrixio_imu,matrixio_env
snd_pcm 98501 5 matrixio_pcm,snd_pcm_dmaengine,snd_bcm2835,snd_soc_core,snd_dummy

Thanks a lot :slight_smile:

Have you solved the issue?

@wichtounet,
Did you solved the issue?

I never solved the issue, I ended up getting rid of the Matrix Voice without having been able to use it once.