Can't connect to http://localhost:3000 with ALEXA

I’ve followed this projet step by step

But at step 6 Linking Your Device to Your Amazon Account , when I type http://localhost:3000 in my browser, it show me Connection failed, Firefox cannot establish a connection to the localhost:3000 server.neither Google Chrome .

But type http://localhost , it go to IIs windows. ping 127.0.0.1 is good.

How to connect http://localhost:3000 to amazong account?

Follow these Instructions:

https://github.com/matrix-io/avs-device-sdk/blob/master/tools/MatrixLabs/README.md

Hello, gapdev

I’ve followed your URL instructions step by step and add client ID ,client secret ,product ID to config.txt. But when I run " bash ./setup.sh ./config.txt" and after typed “AGREE”, It showed
################################################################################
################################################################################
AGREE
################################################################################
Proceeding with installation
################################################################################
make: *** No rule to make target ‘SampleApp’. Stop.

Why this problem?

I’m no authority but it sounds like it is missing some files.

I would delete the Alexa Directory (the one you installed to) and re-do the installation from the beginning.

Kenny

@bluegreen, When following this guide we recommend to start from scratch, from a SD card just Raspbian Stretch. Have you tested that already?