Cant get past pyzmq on install python for matrix creator

Went through installing Matrix Core on Raspi3b+ Buster
Everything fine.

Tried to next install Python
https://matrix-io.github.io/matrix-documentation/matrix-core/getting-started/python-installation/

all steps worked fine then wont get past pyzmq during:
pip3 install -r requirements.txt

Note, after failing 3x, i tried python2 for grins and that worked ok
pip install -r requirements.txt

Any ideas?

Here is the error:

Failed building wheel for pyzmq
Running setup.py clean for pyzmq
Failed to build pyzmq

Command “/usr/bin/python3 -u -c “import setuptools, tokenize;file=’/tmp/pip-install-b12koks5/pyzmq/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-record-ko36vzcf/install-record.txt --single-version-externally-managed --compile --user --prefix=” failed with error code 1 in /tmp/pip-install-b12koks5/pyzmq/

Hi @rickmini,

Would MATRIX Lite Py work for your project or do you particularly need ZeroMQ? Lite Py has much easier syntax and fewer dependencies.

I can try to see if I can replicate and figure out why pyzmq download is not working. It could be that the library does not support the new python version if you have a later version.

Best,
Samreen

1 Like

yes, i did just that. using lite now, and it does everything i need to do.
thx

1 Like