Can't install MATRIX HAL

Hi, I’m new to the Matrix Creator, so new that I have not even been able to test it because I have not been able to install HAL neither CORE.

Here is what I’ve been doing
(trying to install HAL from package), someone please tell me what I’m doing wrong:

Add the MATRIX repository and packages:
curl -L | sudo apt-key add -
echo “deb $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 252 100 252 0 0 1194 0 --:–:-- --:–:-- --:–:-- 1194
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
100 2203 100 2203 0 0 3547 0 --:–:-- --:–:-- --:–:-- 3547
deb bullseye main

Here everything seems to be just fine, then I try this and get:

sudo apt-get update
Hit:1 Index of /debian bullseye InRelease
Hit:3 Index of /raspbian bullseye InRelease
Ign:2 bullseye InRelease
Err:4 bullseye Release
404 Not Found [IP: 443]
Reading package lists… Done
E: The repository ‘ bullseye Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Here things are not looking to be going good, since I get a 404 not found error and a repository with no release file.

Then I proceed to upgrade and everything goes just fine.

Now I’m going to try and install the packages and get this:

sudo apt-get install matrixio-creator-init libmatrixio-creator-hal libmatrixio-creator-hal-dev
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package matrixio-creator-init
E: Unable to locate package libmatrixio-creator-hal
E: Unable to locate package libmatrixio-creator-hal-dev

I’ve been stuck here for a while and don’t know what to do, if anyone knows how to fix this and can help it would mean a lot to me :slight_smile:

They clearly haven’t released a version for the latest Raspbian (Bullseye) yet. It has been a regular occurrence that the Matrix HAL won’t work with the latest version unfortunately. I’m afraid that the price of using small volume development boards like this. Support for Matrix is pretty slow and intermittent. So I would suggest that you build an SD image with Buster (the previous Raspbian version) and try with that.

I will be doing the same on a new build and will let you know how I get on

I did basically what @sjdevlin suggested and flashed an SD card with a Buster Raspberry Pi OS image, and performed the install of Matrix HAL Core utilities from that SD card. This worked out and I am now able to use the development board!

1 Like

Thanks for reminding me to update this @urbushey ! I also rebuilt mine recently with Buster and it is all working fine. Even when you update and upgrade it is all OK. However I think there could be a problem if you do a “dist-upgrade”. I see no need to try - but would be interested if anyone does this and it still works !

1 Like

Thanks!!! I will try this so I can start using the board :smiley:


I also run into this problem, it’s a broken link to a Amazon key. I overcome this I opened by a browser and saved the file “apt-key.gpg” to /Downloads.

Next in the /Downloads directory (or whereever you save this file) you just do
“sudo apt-key add apt-key.gpg” that prompts “OK”.

Next you run the second “part echo “deb $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list” that worked with the activated “apt-key-gpg”.