Could not parse protobuf

Hi All,

I got the following issue when running “matrix-creator-malos/src/js_test/test_humidity.js” . I have updated IP address (127.0.0.1) to the IP of Raspberry PI . While Opening the IP on Browser as “172.19.8.39:20017” . I got the below error

"Message received: Humidity error: 0, Invalid configuration for Humidity driver. Could not parse protobuf "

{ humidity: 34.93241882324219,
temperature: 21.663867950439453,
temperature_raw: 38.2129020690918,
temperature_is_calibrated: true }
{ humidity: 34.93241882324219,
temperature: 22.33193588256836,
temperature_raw: 38.2129020690918,
temperature_is_calibrated: true }
{ humidity: 34.93241882324219,
temperature: 21.663867950439453,
temperature_raw: 38.2129020690918,
temperature_is_calibrated: true }
{ humidity: 34.93241882324219,
temperature: 21.663867950439453,
temperature_raw: 38.2129020690918,
temperature_is_calibrated: true }
{ humidity: 34.93241882324219,
temperature: 21.663867950439453,
temperature_raw: 38.2129020690918,
temperature_is_calibrated: true }
Message received: Humidity error: 0, Invalid configuration for Humidity driver. Could not parse protobuf.
Message received: Humidity error: 0, Invalid configuration for Humidity driver. Could not parse protobuf.
{ humidity: 34.93241882324219,
temperature: 21.663867950439453,
temperature_raw: 38.2129020690918,
temperature_is_calibrated: true }
{ humidity: 34.93241882324219,
temperature: 21.663867950439453,
temperature_raw: 38.2129020690918,
temperature_is_calibrated: true }
{ humidity: 34.93241882324219,

Pls help me to resolve this issue.

@saran Have you git pull and/or git submodule your repo ?
If not, when you are in your matrix-creator-malos folder run the previous git command and it should load the protobuf files

Thanks @JaNe! He’s right, you need to make sure to do git submodule update --init inside the matrix-os cloned repository.

1 Like

@nebil,

I have done the steps you have mentioned Still I’m getting the issue.

@saran

Can you revalidate?

Update Packages

sudo apt-get update && sudo apt-get upgrade
```

#### Update Repository
```
git pull
git submodule update --init
```

Let us know.

Hi @saran,

Can you run test_humidity.js for a longer period and share the result. I want to see how frequent are you getting this error.
Also would be important to know if the other test have errors too or if is just this one.

Yoel

Hi @Yoel,

I will get the error when i try to connect the IP address (172.17.8.87:30017) with Browser(Firefox).
I tried with IMU , Humidity , Everloop , Pressure . I all those examples I am getting the same issue.

@saran

After updating the IP in the files, run the JS files node test_humidity.js. You shouldn’t need to use a browser.