Current Audio recording Sampling Rate Supported by Matrix Creator board

I have played with micarray_recorder in HAL demo and I can get upto sampling rate upto 48 KHz across 8 channels by using the ‘SetSamplingRate’ function in microphone_array.cpp. Is it the highest sampling rate possible ? I tried with 96KHz with no success. Does the Matrix Voice support microphone recording upto 96 KHz across 8 channels ?

Hi @swadhinp,
Currently, only frequencies from 8 kHz to 48 kHz are supported. Do you specifically need 96 kHz?

Yes, I do need 96KHz sampling rate and that is one of the reason I bought matrix voice or creator. I remember that you guys have promised to provide 96Khz sampling rate. I want to record ultrasonic signals of higher frequency and 96KHz will allow me to record upto 48KHz. Will there be any future update regarding this ?

Hey! @swadhinp good news!
Is not currently available but I just double checked and 96Khz will be included in next releases. I will personally let you know here in this post.

Hello @swadhinp,

We are close to releasing the 96KHz support.


Kevin Patino

Is 96KHz available now?

yes it is. :slight_smile:

Does it need special settings?

To test whether it works, I simply changed the frequency values in micarray_recorder_direct.cpp from 16000 to 96000. I recorded 1000hz tone. Sampling frequency 16000, 48000 did record the 1000hz tone correctly and I was able to convert it to wav and play it. However, when I changed it to 96000, the recorded tone became distorted to a lower tone and was noisy.

Has anyone successfully used 96khz? If so, what am I doing wrong?

Hello @kaios0002,

I use the matrixio-kernel-modules and run the following command:

$ sudo apt install sox
$ rec -r 96000 -c 8 96KHz.wav

Input File     : 'default' (alsa)
Channels       : 8
Sample Rate    : 96000
Precision      : 16-bit
Sample Encoding: 16-bit Signed Integer PCM

In:0.00% 00:00:06.83 [00:00:00.00] Out:654k  [      |-     ]        Clip:0    ^C

Best Regards,

Kevin Patino

Great. I am able to record in 96Khz now. Have you succeeded to get 8 separate files? I have tried the -I option in arecord but did not work.