Defective temperature sensors?


#1

Got my Matrix Creator last week end, and my first project I had was to upgrade my small “weather station” with it.
Well, it’s not really a “weather station” as it only monitor temperature, until now :slight_smile:
Anyway, upgrading my old DS18B20+ with the Creator sensors seems a good starting point to learn how the matrix core works.

Despite the fact that both temperature values from humidity & pressure sensors are off the reality, mainly due to the heat coming from the pi and/or the Creator itself (I think), the reading from the humidity sensor is completely flat.
Whatever the actual temperature in the room, the only value i got is pretty much 33.0.
(I’m only talking about the raw temperature, not the calibrated one).
I’ve tried to restart the Pi/Creator, and reflash everything, but nothing, still 33°C.

Here is a few temperature readings I got tonight :

I use a fan to lower the temperature around the Creator, and as you can see, the pressure sensor follow the same trend as the CPU temp. But the humidity sensor just stay flat.

Actually, it’s not really flat. If you take a closer look :

There is some variation, but extremely small, and in the opposite direction !

So, either my humidity sensor is busted (but in other hand, the humidity value is quite correct), or something else is wrong.
Before sending my Creator back for a replacement, I would rather know if someone else has already had this issue or not.


#2

tldr; my sensor is indeed damaged :frowning:

I did some digging today, and tried to query the sensors using the i2c bus directly from the Pi.
There is 2 calibrations points saved in memory, used to do a linear interpolation of the measured value in order to get the final calibrated temperature.
On my sensor, the first one, T0_OUT, is at 20°C for a raw value of 0xFFFE (65534)
The second one, T1_OUT, at 33°C for a value of 0x0281 (641).
At this time, the room was near 22.1°C and the sensor gave me a raw value of 0x0246 (582).

The T0_OUT value is clearly the issue here, as it is above T1_OUT (when it should be below, that’s why the small variations I’ve previously observed were reversed), and it’s way too far from T1_OUT to make any temperature variations noticeable.
Unfortunately, I don’t think I can fix this by myself, as the calibration points are overwritten at boot time.


#3

Thanks for the in-depth analysis, I will be checking this findings.
Will be back with some answers :slight_smile:

Yoel


#4

Hi

I’m having issues with the sensor readings too. The temperature readings from the humidity sensor is reading about the same (33 degC), which could indeed suggest that the heat from the creator is the reason for this, my room’s currently 17.6 degC. However my humidity reading does work, although it’s waaaay off! I haven’t looked in to this much at all as my main focus is the microphone array, and I’m unaware how to calibrated readings as of yet but hope to have a look in to it at some point soon!.

George

41|443x256


#5

pic ----> 41