Google Assistant: ModuleNotFoundError:

Hey Dudes and Dudines,

I encounter a lot of difficulties by setting up the Google Assistant. I followed the YouTube Tutorial Ep. 119 with Carlos and Samreen from April 2019.


mainly everything works fine until i get to the point where everything comes together to first time start the Google assistant by using -> ~/google-assistant-matrixio/google-matrixio-assistant-hotword --project_id your-dev-project-id --device_model_id your-model-id

so, i replace your-dev-project-id and your-model-id with my ID’s and hit Enter,

but then i get the following Fail-Message:

(env) pi@raspberrypi:~/google-assistant-matrixio $ ~/google-assistant-matrixio/google-matrixio-assistant-hotword --project_id kiraassistent-kira --device_model_id kiraassistent-kira-tg6v7w
Traceback (most recent call last):

  • File “/home/pi/google-assistant-matrixio/google-matrixio-assistant-hotword”, line 7, in *
  • from matrixio.hotword import main*
  • File “/home/pi/google-assistant-matrixio/matrixio/hotword.py”, line 27, in *
  • from google.assistant.library import Assistant*
    ModuleNotFoundError: No module named ‘google.assistant.library’

yes, i installed git and cloned google-assistant-matrixio.git before running the command, i’m also inside the Pyhton virtual environment ENV.

am i missing something?

i already started on 2 different fresh SD-Cards and tried to often to sudo rm -r , deleting all the folders and starting over and over, but in the end i get stuck always on this very last message.

also if someone wants to connect via TeamViewer or similar to go trough this with me, it would be a honor.

i would summarize and post the solution here when it worked

leave me a comment!

thanks

Hi @KiraKarani,

Welcome to the community!

What version of Raspbian are you using (Stretch, Buster)? We have yet to test our Google Assistant guide on Raspbian Buster and so there may be bugs we haven’t encountered yet.

We’ll test & get back to you ASAP!

Best,
Samreen

1 Like

Hey Samreen!

thanks for your Reply.

I’m using following OS downloaded by Raspberrypi.org:

### Raspbian Buster with desktop
Image with desktop based on Debian Buster
Version: July 2019
Release date: 2019-07-10
Kernel version: 4.19

meanwhile i will check if i can reproduce with Stretch

best regards,
Karani

1 Like

Hey there!

so i installed Raspbian Stretch and startet all over, now it works!

so it seems like it is currently not compatible with Buster

i will use this for a while! thanks for your hint and support

1 Like