HAL only set-up

I only want to use HAL and want the final set up to avoid conflicts with MALOS, etc.

When I build HAL on a clean install of raspbian I can’t get the demos to run. First, it gave me SPI errors, so I enabled SPI on the PI using the config tool. Now, when I run the demos, the board does nothing, but from the PI’s terminal, it looks like it is running.

Does anybody know how to just set up the Matrix board with a PI using only HAL? Does installing MALOS or MATRIX OS install some raspbian package that is required for the board to work? Does it have something to do with the DEVICE_ID/SECRET?

To be clear, I have one PI SD card that has all the stuff on their (HAL, MALOS, MATRIX OS, etc) and then another SD card that just has HAL – the former still works, but the latter doesn’t.

Thanks in advance for any help!

The problem an my side was no Firmware for the fpga. Alter flashing it the Clock Worked (./everloop_demo)

hire ist the step by step
#install missing pkg

sudo apt install libftdipp-dev libusb-dev
cd ~
git clone https://github.com/matrix-io/xc3sprog.git
cd xc3sprog
mkdir bin
cd bin
cmake ..
make
sudo make install

cd ~
wget http://packages.matrix.one/matrix-creator-firmware/firmware-0.8.tar.gz
tar xf firmware-0.8.tar.gz
sudo xc3sprog -c matrix_pi firmware-0.8/blob/system.bit -p 1

And now it Work (the led Demo)

after this i make

sudo apt install  libtool automake libftdipp-dev texinfo autoconf libusb-1.0-0-dev
git clone https://github.com/matrix-io/matrix-creator-openocd.git
cd sudo openocd -f cfg/sam3s.cfg
./bootstrap
./configure --enable-sysfsgpio --enable-bcm2835gpio
make
sudo make install

und now it the Time to Flash

cd
cd firmware-0.8
sudo su
echo 18 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio18/direction
echo 1 > /sys/class/gpio/gpio18/value
echo 0 > /sys/class/gpio/gpio18/value
echo 1 > /sys/class/gpio/gpio18/value

sudo openocd -f cfg/sam3s.cfg
exit

because the FPGA do not hat an eeprom you ´have to programm it everytime after a power cycle

so my solution is an crontab line

sudo crontab -e

insert

 @reboot cd /home/pi/firmware-0.8 && sleep 1  && sudo xc3sprog -c matrix_pi blob/system.bit -p 1  && sleep 1 && sudo openocd -f cfg/sam3s.cfg

Greet Anton

1 Like