Have problem when try to install matrix OS with CLI

I directly use HDMI to connect my raspberry pi to a monitor rather than remotely access to my pi.
So is there any method that I can directly get matrix OS on my raspberry pi? Since right now I installed the matrix CLI on my mac, (in order to get the ID and SECRET), and follow the instruction here: https://matrix-io.github.io/matrix-documentation/.
But I always got the message that told me to pair device via bluetooth:
~/matrix-os $ sudo NODE_ENV=rc node index.js
Environment Selected: rc
Loading… device
Loading… event
Loading… service
Missing registration information! This device is not correctly configured.
You can register and pair via Bluetooth to your device using the MATRIX mobile apps.
Alternatively, you can use MATRIX CLI to register the device manually to then add the MATRIX_DEVICE_ID and MATRIX_DEVICE_SECRET variables.
If you continue to have problems, please reach out to our support forums at http://community.matrix.one
…….

I’m sure I already register the ID and SECRET,
so 1st question: how to use bluetooth to pair my pi and Mac? (even I made these two bluetooth enabled, my devices cannot detect each other)
2nd question, what else can I do to install matrix OS without CLI.

Thanks.

Im having pretty much the exact same issue and i have tried everything. I dont think the problem is with you not using CLI because Im SSHing and getting the same problems. Can anyone help?

Concerning the “Missing registration information!” try that command without sudo “NODE_ENV=rc node index.js” I tested with sudo, it gives that message “missing registration information” but it worked when I didn’t use the sudo.

The reason is because you have added the MATRIX_DEVICE_ID and MATRIX_DEVICE_SECRET to the environment for your user. When you use the command ‘sudo’ it allows users to run programs with the security privileges of another user, by default the superuser. So you are actually launching the Matrix application as the superuser user and not your user. You are getting the message because those environment variables don’t exist for the superuser. I did the following commands:

  1. sudo su
  2. edit the ~/.bashrc file or ~/.envrc file to include the ‘export MATRIX_DEVICE_ID=’ and ‘export MATRIX_DEVICE_SECRET=’ values.
  3. exit
    At this point you should be back as your user again.
  4. sudo NODE_ENC=rc node index.js

TL;DR, Switch to the super user account, put your environment variables in there, save, and try again as your user.

1 Like