Headphone jack with no output once Matrix Creator plugged in

Hi,

My issue is that once I plugged the Matrix Creator and tried to use aplay to play a sound (which I’m sure it has content). But I cannot hear anything from the headphone. Even when I opened the Youtube video,
However, once I unplugged the Matrix, then EVERYTHING works fine.

I don’t have .asoundrc file, but my /etc/asound.conf:

> pcm.sc {
>     type hw
>     card 1
> }
> 
> pcm.mic_channel0 {
>   type file
>   file "/tmp/matrix_micarray_channel_0"
>   infile "/tmp/matrix_micarray_channel_0"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> 
> pcm.mic_channel1 {
>   type file
>   file "/tmp/matrix_micarray_channel_1"
>   infile "/tmp/matrix_micarray_channel_1"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> 
> pcm.mic_channel2 {
>   type file
>   file "/tmp/matrix_micarray_channel_2"
>   infile "/tmp/matrix_micarray_channel_2"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> 
> pcm.mic_channel3 {
>   type file
>   file "/tmp/matrix_micarray_channel_3"
>   infile "/tmp/matrix_micarray_channel_3"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> pcm.mic_channel4 {
>   type file
>   file "/tmp/matrix_micarray_channel_4"
>   infile "/tmp/matrix_micarray_channel_4"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> 
> pcm.mic_channel5 {
>   type file
>   file "/tmp/matrix_micarray_channel_5"
>   infile "/tmp/matrix_micarray_channel_5"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> pcm.mic_channel6 {
>   type file
>   file "/tmp/matrix_micarray_channel_6"
>   infile "/tmp/matrix_micarray_channel_6"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> pcm.mic_channel7 {
>   type file
>   file "/tmp/matrix_micarray_channel_7"
>   infile "/tmp/matrix_micarray_channel_7"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> pcm.mic_channel8 {
>   type file
>   file "/tmp/matrix_micarray_channel_8"
>   infile "/tmp/matrix_micarray_channel_8"
>   format "raw"
>   slave {
>     pcm sc
>   }
> }
> 
> pcm.!default
> {
>   type asym
>   playback.pcm {
>     type hw
>     card 0
>     device 0
>   }
>   capture.pcm {
>     type file
>     file "/tmp/matrix_micarray_channel_0"
>     infile "/tmp/matrix_micarray_channel_0"
>     format "raw"
>     slave {
>         pcm sc
>     }
>   }
> }

I tried on both Pi2 and Pi3, same thing happens

Not sure if this would help, but you can do:
sudo raspi-config

Then choose option 7, Advanced Options, and option A4 to force the sound to the audio jack.

I’m clueless to how asound.conf works, but below is a copy of mine for reference.

pcm.!default {
  type asym
  capture.pcm "mic"
  playback.pcm "speaker"
}

pcm.mic {
   type softvol
   slave {
     pcm "array"
   }
   control {
     name "MicArray Master"
        card 0
   }
}

pcm.speaker {
  type plug
  slave {
    pcm "hw:0,0"
  }
}

pcm.array {
  type plug
  slave {
    pcm "hw:2,0"
  }
}

Can you also share the output of :

sudo dpkg -l | grep matrix
lsmod | grep matrix

Hi, I fixed it.
I think the reason it does not work is because the audio output is automatically mapped to HDMI.
Once I switch from monitor to Pi Touchscreen, I can hear audio output.
I believe there is another way to manually force the audio output not to HDMI, but I don’t remember the detail. It is something like just change one line in .asound.conf file.