Help with zipgateway

Hi there,

Got my Matrix CREATOR + Raspberry Pi 3 B
All good except the zwave part.
I followed the instructions from GitHub malos-zwave but I can’t get zipgateway to spit anything else but SERIALAPI error:

pi@raspberrypi:~ $ more /tmp/zipgateway.log
23996 Opening config file /usr/local/etc/zipgateway.cfg
Starting Contiki
Opening eeprom file /usr/local/var/lib/zipgateway/eeprom.dat
Lan device tap0
LAN HW addr 12:EF:1F:04:F0:B2
24019 Starting zipgateway ver2_61 build ver2_61
24019 Resetting ZIP Gateway
24019 Using serial port /dev/ttyMATRIX0
SerialAPI: Retransmission 0 of 0x07
SerialAPI: Retransmission 1 of 0x07
SerialAPI: Retransmission 2 of 0x07
SerialAPI: Retransmission 3 of 0x07
SerialAPI: Retransmission 4 of 0x07
SerialAPI: Retransmission 5 of 0x07
SerialAPI: Retransmission 6 of 0x07
SerialAPI: Retransmission 7 of 0x07
SerialAPI: Reopening serial port
SerialAPI: Retransmission 8 of 0x07
SerialAPI: Retransmission 9 of 0x07
SerialAPI: Retransmission 10 of 0x07
SerialAPI: Retransmission 11 of 0x07
SerialAPI: Retransmission 12 of 0x07
SerialAPI: Retransmission 13 of 0x07
SerialAPI: Retransmission 14 of 0x07
SerialAPI: Retransmission 15 of 0x07
SerialAPI: Reopening serial port
SerialAPI: Retransmission 16 of 0x07
SerialAPI: Retransmission 17 of 0x07
SerialAPI: Retransmission 18 of 0x07
SerialAPI: Retransmission 19 of 0x07
SerialAPI: Unable to send frame!!!
SerialAPI: SendFrameWithResponse() returning failure
…) failed in SerialAPI_Init()
SerialAPI: Assertion failed at /drone/src/
73238 Error opening serial API
73238 Fatal error

This is my /usr/local/etc/zipgateway.cfg:

ZipUnsolicitedDestinationIp6 = fd00:aaaa::1234
ZipUnsolicitedDestinationPort = 41230
#ZipUnsolicitedDestination2Ip6 = fd00:aaaa::1234
#ZipUnsolicitedDestination2Port = 41231
#SerialLog = /tmp/ziprouter.serlog
ZipLanGw6 = fd00:aaaa::1234
#ZipTunPrefix = 2000::
#ZipTunIp6PrefixLength = 128
#ExtraClasses= 0x43 0x75

Other info:
. connecting to internet using Wifi
. when running configuration for zipgateway, I am not sure about what to input for **Enable wireless configuration of Z/IP Gateway ** or for Wired network interface where the ZIP Client will be connected to
. When I ran zwave_conf everything looked fine. But I’ve run it again a few times (I know I probably shouldn’t have) and the output is:

pi@raspberrypi:~ $ sudo zwave_conf
ID.conf: line 1: INFO:: command not found
*** FFFFFF does not MATCH – FAIL

I’ve tried compiling zwave from source, etc…
I am completely lost and losing it.

Any advice, pointers, tutorials?
Thanks a lot

This is really frustrating.
Is there anyone in the community that got it working?
Please, would you publish step-by-step what you did?
Really appreciate it

I will keep posting a different error a day until:
. I get some kind of help
. I return the board

Today’s error brought to you by:

more /tmp/zipgateway.log

SerialAPI: Assertion failed at /drone/src/

Any ideas?

Today’s error brought to you by… libzwaveip

./reference_client ./reference_client -s fd00:aaaa::1234 -p 123456789012345678901234567890AA
connect: Network is unreachable
Error connecting

Anyone? Any suggestions? Time to return the board and get something else?

Hi @jordimo,

Sorry for the delayed response to this. I tried to setup ZWave today from the Github malos-zwave repo and was able to get it working so let’s see how we can troubleshoot your errors to have it work for you too.

Your zipgateway.cfg file is the same as mine so I assume you configured it the same way I did, but just to make sure, I followed the configuration on the GitHub exactly even though I am also using a wireless internet connection.

  • The serial port where z-wave controller is connected: /dev/ttyMATRIX0 [mandatory]
  • The IPv6 address of the Z/IP Gateway: fd00:aaaa::3 [optional]
  • IPv6 prefix of the Z-Wave network: fd00:bbbb::1 [optional]
  • Enable wireless configuration of Z/IP Gateway: wired [optional]
  • Wired network interface where the ZIP Client will be connected to: eth0 [optional]

Also, make sure to reboot after running zwave_conf.

The SerialAPI errors you are getting indicate that there is something wrong with your UART connection. While I am not sure why that is, I suggest starting the guide on a fresh install of Raspbian Stretch to ensure that no other processes are interfering with the UART serial bus.

Once you get more /tmp/zipgateway.log to log properly, let me know and I can help you out with the rest of the installation. The GitHub repo has code that allows you to detect and send messages to Z-Wave devices through Javascript. I mostly followed the GitHub guide but did a couple of minor things differently.

Worst case scenario, if nothing seems to work for you, I can make an image of the SD card which has the working Z-Wave code on it and pass it along to you.


Thanks for the response!

I am OTO until tomorrow night. I will give it a shot.
The only thing I can think of I might have done different is running zwave_conf a few times (first time worked, the rest it gave me errors).

I will try a new clean install of Stretch + GitHub instructions.

But, in all honesty, SD image would be great since it would tell me I was doing something wrong pretty quickly or if there’s something wrong with the board.

So, tried exactly what you said:
. clean Raspbian installation
. followed steps from GitHub malos-zwave


sudo zwave_conf
ID.conf: line 1: INFO:: command not found
*** FFFFFF does not MATCH – FAIL

(I imagine because I run it before, so ZM5202 already has the right configuration)

sudo apt-get install matrixio-malos-zwave
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
matrixio-malos-zwave : Depends: matrixio-protobuf but it is not going to be installed
Depends: libmatrixio-malos but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After installing manually the dependencies, I can install matrixio-malos-zwave
Same config than you.
Still, after rebooting, /tmp/zipgateway.cfg still shows SerialAPI error.

I think it’s worst case scenario.
I’d love if you could make an image of your setup.