Illegal instruction


#1

Hi all,

I get the following when I run NODE_ENV=rc node index.js

Environment Selected: rc
Loading… device
Illegal instruction

I have run this on a raspberry pi B+, and a raspberry pi zero, with fresh installs of raspian jesse (v8). I have even returned one matrix creator unit under the assumption it was faulty and the new unit gives the same error.

Please can any one help indicate what the problem may be.

Kind regards

Paul


#2

Hi @kenders2000 Can you run it with the DEBUG=* flag? DEBUG=* NODE_ENV=rc node index.js


#3

Hi Lucas, when I do that I get the following:
pi@kenderszeropi:~/matrix-os$ DEBUG=* NODE_ENV=rc node index.js
Environment Selected: rc
Loading… device
device Loading… device > gpio +0ms
device Loading… device > heartbeat +53ms
device Loading… device > malos +44ms
device Loading… device > network +17ms
device Loading… device > port +801ms
device Loading… device > sensor +22ms
device Loading… device > service +21ms
device Loading… device > system +30ms
device Loading… device > wifi +18ms
device Loading… device > driver > accelerometer +21ms
device Loading… device > driver > altitude +23ms
device Loading… device > driver > detection +21ms
device Loading… device > driver > gesture +25ms
device Loading… device > driver > gpio +23ms
device Loading… device > driver > gyroscope +23ms
device Loading… device > driver > humidity +22ms
device Loading… device > driver > ir +22ms
device Loading… device > driver > led +22ms
device Loading… device > driver > magnetometer +42ms
device Loading… device > driver > mic +20ms
device Loading… device > driver > pressure +80ms
device Loading… device > driver > recognition +22ms
Illegal instruction
Any ideas?

Thanks!

Regards

Paul


#4

hello,
you have found a solution to this problem ?

thanks