IR / LIRC not working


#1

Hello,

I followed the “getting started guide” to setup and start testing my matrix creator (OS v0.15.0) with a Raspberry Pi 3. The IR part (especially while SENDing) doesn’t seem to work for some reason.

First, when trying matrix.ir(…) it throws an exception, because matrix object doesn’t have any ir property attached to it (i checked it with a console.log(matrix.ir) and it shows “undefined”).

Then I moved to simple lirc commands, and here’s what happens:

  • Command “mode2 -d /dev/lirc0” does show some output when I press buttons on my remote, also the blue LED blinks
  • Command “irsend SEND_ONCE SONY KEY_POWER” (I have a config for a remote named SONY) shows an error:

irsend: could not connect to socket
irsend: No such file or directory

So, I tried a sudo lircd, and after that that I get a new error:

irsend: command failed: SEND_ONCE Samsung_BN59-00940A KEY_POWER
irsend: hardware does not support sending

Am I missing something ? please advise.

Thanks


#2

Hi @airslim sorry for the delay. The IR branch is not merged yet, we have it on our updates list but we couldn’t tested yet. Because of that, the IR is not operational for now and that’s why you are receiving an exception. We hope make it operational asap. We will remove that section from the documentation until it is working.

Regards,

Lucas


#3

@lucas any updates about when the IR will be operational? I’m having the same issue…

Thanks
Aku


#4

Alright turns out it was actually Raspbian Stretch that was causing the issue with IR. I found out there’s a script you have to manually execute to get LIRC operational: sudo /usr/share/lirc/lirc-old2new.sh.

source: https://www.raspberrypi.org/forums/viewtopic.php?t=192891#p1212574


#5

Hi @Accu we have tested for blasters and tv remotes. But it should be working normally as well.
This script you have execute worked normally?


#6

After that script LIRC started working normally so I think the issue was there instead of Creator, but yeah.


#7

Actually I did a fresh install on another matrix board, using the latest raspbian stretch image and I do not seem to get the IR working… LIRC had to be installed manually, and dtoverlay=lirc-rpi uncommented in /boot/config.txt… and even though lirc daemons appears to be working, ls /sys/class/rc doesn’t show anything… Please help!


#8

Now that I compared the fresh install against the working one I have, it seems like MALOS does not start LIRC driver at all… also I’m not getting any input in mode2 -d /dev/lirc0 either


#9

Ok so after 3 days of searching, I managed to notice that matrix-creator-init completely dropped LIRC support so that’s probably why the newer matrixio-* packages did not work. I managed to get IR working by adding jessie repository to /etc/apt/sources.d/jessie.list and installing the older matrix-creator-* packages…

Looking at the test_ir_remote.js file, there is absolutely no way that test can work without LIRC support… so if there is an alternative way of sending IR, what would be it? And if not, why drop IR support altogether? Can @lucas or someone confirm this?


#10

another user still interested in a reponse to this topic question…? does lIRC work? i actually have the Voice, not Creator…