Is there any way to check whether the device is broken or not?

Hi all.
I’m trying to get the microphone array in MATRIX to work.
Furthermore, I need to get it working at HAL level so that I can directly implement programs using c++.
Unfortunately, I can’t get the MATRIX to work.
I think I’ve tried almost everything, including CLI and OS.
quickstart guide, hal install, enabling SPIs and so forth.
I think I’ve resetted Raspbian about 5 times, just today.

I now have the SPI open
so I’m getting something, but I don’t think MATRIX is properly responding. I keep getting 0 on MCU ID and whatnot when I run all the demos. nothing on everloop, micarray codes, 0 on humidity, 0 on yaw,roll,pitch,pressure,temp,you-name-it,etc. (also 0 on MCU version).

What am I doing wrong?
Have I broken my MATRIX?
If I have, is it possible for me to check if I’ve broken it or not?
Someone please help me out here…
Thanks in advance.

Hi @JeeSokLee,

It looks like some how your MCU is not been programmed. When the MCU firmware runs it blinks a blue tiny LED close to the Atmel MCU. So If it doesn’t blink you can try to program it again doing :

cd /usr/share/admobilize/matrix-creator/
sudo ./sam3-program.bash

Finally you can check and share with us the log in /tmp/sam3-program.log

Yoel

will most certainly do so, but need to get the admobilize/matrix-creator up and running first. thank you so much :slight_smile:

Ok let me know after you try to reprogram it again.

Yoel

@yoelrc88
Okay… unfortunately, I’ve done something wrong (again) and the log wasn’t created.
Fortunately, for whatever wrong I must’ve done (haha), the device is now working pretty well.
(so all in all, my device does work…)

Let me try to recreate what I’ve done and I’ll get back to you with specifics on how to get this stuff working.

Okay this is embarrasing…
I did get it to work, and the key was to install the whole thing from
https://github.org/matrix-io/matrix-creator-quickstart

I started the quickstart right after I installed NOOBS, otherwise known as RASPBIAN OS.
nothing else, directly git clone it and install it.

The problem was me trying to do the whole thing step-by-step independently
(in my defense, I didn’t know the whole thing existed…)

Anyways, thanks @yoelrc88 for helping.