Matrix CLI - Register device => Error: Timeout queue.js:79:18

Hi

I have an issue when i try to register my device.
I can login but when i try to register… i got this message:


I tried to register and login, with and without sudo… on both cases, i get this timeout error =/

Thanks for your help on it

2 Likes

Encountered same error this weekend - possibly an issue with rc platform (not sure). Was able to setup an account and register using the dev platform instead:

matrix set env dev
matrix register
matrix register device

Hope this helps.

1 Like

Hey @LengZai, sorry for the late reply. @skdev is right, that message is displayed when you don’t get a quick response from the server. When that happens you can try again in case something went wrong with your local connection, or wait a few minutes and give it another try in case the server had a hiccup. Alternatively you can use the dev environment, however, keep in mind that dev is bound to be a bit unstable and users, devices and apps are not shared between dev and rc. We’ll are planning to change the timeout message for a friendlier version.

I also want to encourage you to use the CLI without sudo, after a recent update that is no longer necessary :grin:

It’s been two days and I am just not able to register and move to test this product. Cab anyone suggest me something that may help please.

Also, in spite of getting this error I see the device gets added, nut now how do I acquire the MATRIX_DEVICE_SECRET… Any ideas would help.