Matrix-creator-alexa-voice-demo

My first project with the Matrix Creator was just to try a canned demo so I tried this Amazon Alexa demo. The install went well and the demo runs without errors, but it does not behave as expected. All the LEDs on the Matrix are flashing all different colors and the demo does not sense when I touch the IR sensor. Anyone get this demo to work ok and any idea what is going on with my setup. I have a Pi 3, new NOOBS installation (Jessie and Pixel).

Thanks.

Hi @danno,

Regarding the LEDs, following your description it seems a power issue. Try to use any other power supplies you have. If you don’t have others you can try a 5V 2Amp phone charger. Here is a link of power supply from CanaKit that we have tested https://www.amazon.com/CanaKit-Raspberry-Supply-Adapter-Charger/dp/B00MARDJZ4.

Let us know how was the test and if you have any other issues.

Yoel

Hi @danno,

Also we recommend to use the Raspbian Jessie Lite version. The Pixel one probably eats more RAM.
https://downloads.raspberrypi.org/raspbian_lite_latest

Yoel

Thanks Yoel,

Tried three different supplies with limited success. I’ll have to write some short programs to test out different aspects of the board to see what is going on. The Pi3 is running fine and I’ve tried with a 2A and 3A supply intended for the Pi as well as a phone supply and all three exhibit what I would call out of control LED firing. If the Matrix board is that sensitive to the power when the Pi runs flawlessly I think you have some decoupling, filtering, or signal integrity issues that do not give me a warm fuzzy feeling. I will experiment further to try to get to the core of the issue.

Dan