Matrix creator broken?


#1

Hi, I have two Matrix creator boards which I bought together. I am trying the Alexa python demo on each of them http://www.instructables.com/id/Build-DIY-Amazon-Alexa-With-a-MATRIX-Creator-on-Ha/.

While I am able to run it one one board, the other seems to get stuck while looking for a microphone. I also tried recording with ‘arecord’, and it seems to have the same behavior. The presumable ‘faulty’ board gets stuck on calling ‘arecord’, while the other board starts the recording.

I also notice that the ‘faulty’ board does not have the D50 led on, while the other one has. Does this point to any hardware problem with the board? Or is it some other issue which can be fixed at a software level?

Thanks.


#2

Hi @ictdev,

It seems a software issues. Few points here

  • The D50 LED is related to the Zigbee chip , so thats no a problem.
  • Have you tried putting the ‘faulty’ board in the Rasp Pi + SD card that worked with the ‘Good’ board?
  • Also would recommend to start the setup from the begining with the 'faulty ’ board.
  • Regrading the test with the arecord. Have you tried to record different channels ?
    arecord --device=mic_channel1 -r 16000 -c 1 -f S16_LE test.wav
    using mic_channel# with # from 0 to 8.

Let us know how it goes :slight_smile:


#3

Hi @yoelrc88, thanks for the reply.

I have tried the ‘faulty’ board with the Rasp PI + SD card that works with the ‘good’ board. Here is my test setup:

  1. I connect the ‘good’ board with RPI v3 and boot it.
  2. Start a recording with arecord which expectedly outputs “Recording WAVE ‘test.wav’ : Signed 16 bit Little Endian, Rate 16000 Hz, Mono”.
  3. Then I shut down the RPI, attach the ‘faulty’ Matrix creator on the same PI, and restart it.
  4. Repeat Step 2, but instead of recording, it just gets stuck with no output. I repeated it with all channels (0-8) and got the same result.

So I think it’s not a problem with the software on RPI. Any other ideas? Thanks.