Matrix Creator: Could not Program FPGA / NO JTAG Chain FOUND

First, sorry for my english :slight_smile:

The university had ordered a matrix creator a few months ago for my project. Since last week Monday I’m trying to run the installation and could not rule out if it’s a hardware issue.

Raspberry Pi 3
Image: Last Version from stretch

On start

D48 ist blinking very fast.

after execution of the hardware test from the site


I thought that maybe it was fpga problem and tried this site.



What is the problem now? With Raspi Config I have also set. I ask for a detailed installation guide. So that I can rule out a hardware defect?

Hi @Zeliha,

It seems the issue lies with the MATRIX package installation. The hardware is not accurately detected unless the matrix-creator-init package is properly installed. Let’s troubleshoot why you’re having the software installation issues and that in turn will help us test the hardware.

Can you send the output of the following commands?

  • uname -a
    This will tell us what version of the Linux kernels your Stretch image has. If this is Linux kernel version prior to 4.19, there may be installation issues since all our packages have been updated for the latest kernel

  • dpkg -l | grep matrix
    This will tell us what MATRIX packages were installed on your Raspberry Pi and the status of the installation i.e. whether there were any issues. Depending on the output of this, you may want to uninstall and reinstall the matrix-creator-init package

I would also recommend double checking that your power supply is rated at 5V 2.5A as the MATRIX Creator can be sensitive to power demands.


Hey Samreen, thanks for reply!

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

We tested three power supplies.

Best regards

Everything seems okay there. I know you sent versions of this already, but can you send the output of below?

cd /usr/share/matrixlabs/matrixio-devices


If the FPGA is still not detected, I would recommend uninstalling the creator initialization package with the command below.

sudo apt purge matrixio-creator-init

Then reinstalling it, just to be completely sure.

Add repo & key

curl | sudo apt-key add -
echo "deb $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list

Update & upgrade packages

sudo apt update
sudo apt upgrade

Install the init package

sudo apt install matrixio-creator-init

Then reboot to allow flashing to occur

sudo reboot

Check FPGA info

cd /usr/share/matrixlabs/matrixio-devices

Let me know how it goes!


I will be again in the Lab on monday. I will send the output of the fpga Info to you then on monday. Thanks for the effort.

I have already implemented your second suggestion exactly as you explained which is to reinstall the drivers. However, I am going to make reinstallation again.

Best regards

1 Like