Matrix Creator Pairing

Hi,

i followed the guide to setup Creator and Pi.
I createda account , logged in, registered the device and everythings works well.

I created the first app and was able to deploy start and stop it. :slight_smile:

Now i installed the app on my iphone, entered login data and my device is shown, but OFFFLINE.

Then i read the pairing guide, so i repower the system, blue led is blinking, try to find new bluetooth devices … nothing.

The app on my mobile shows “Not connected to a network Tap here to configure one”

There is also MXSS Disconected and then sometimes connected (toggeling).

Is there a way to check if bluetooth is working on the CREATOR ?

The creator does not have a bluetooth build in, possibly only the rpi 3 itself. The Voice with the ESP32 chip has bluetooth.

Hmm maybe it is realy possible to pair this with the bluetooth on the rpi, never tested this.

I tried the app, but I can’t log in.

That’s make sense. I thought it has Bluetooth.

So the documents regarding to pairing is only for the Voice.
https://matrix-io.github.io/matrix-documentation/matrix-os/getting-started/pairing/

May be it is helpful to add these information to the docs. But it is also clear that it is not working without the hardware on the Creator.

Another question:slight_smile:
When I starting node index.js there is a hint that there is an update 1.7.0 to 1.7.1.
How to do this?

Thanks in advance

i also got the hint

 _  _ ____ ___ ____ _ _  _
 |\/| |__|  |  |__/ |  \/   [o__o]
 |  | |  |  |  |  \ | _/\_  v0.17.1-22211c5
MATRIX OS can be upgraded. 0.17.0 available! 0.17.1

i also did a git pull before, i would ignore it. as it says v0.17.1-222… above

but how did you login with your mobile app, i can not login with it.

update
now i can login but my device shows as offline …

update
it seems that the mobile app is working on the dev environment, as i used an other name for my device there, but “NODE_ENV=dev node index.js” throws websocket errors.

stream Init Streaming Server: wss://dev-mxss.admobilize.com/engine.io?..... socket error: websocket error

so i’m running in production / rc env right now.

have to test this. So we had 3 enviroments right?

Production = node index.js

DEV = NODE_ENV=dev node index.js

RC = NODE_ENV=dev node index.js

Are there infomations about each enviroment?

Best regards

TuxTux

hmm i think it is
DEV:
NODE_ENV = DEV

RC / PRODUCTION (i believe they are the same, but not sure, or production is mapped to rc):
NODE_ENV = production / rc

Right, its the same i belive. It is sad that we have to belive -.-

But have tested the dev enviroment and cannot start the matrix-os.

sdk [post] body: { status: 'error', status_code: 400, error: 'Device not found.' } +224ms
  sdk Device Error { status: 'error', status_code: 400, error: 'Device not found.' } +7ms
API Error:  400 - Device not found.
Unable to setup online MOS, something went wrong (400) (Device Token Retrieval Error)
Bad Matrix Initialization Device Token Retrieval Error
  matrix DESTROYING +2s
  matrix Firebase wasn't initialized +2ms
Cleanup complete...

rc is starting like production.

for dev you have to create your own login and devices with matrix-cli:

matrix set env dev
matrix register / login
... and so on ...
generate new tokens and then set them in the .bashrc
1 Like

Ok, make sense. But not userfriedly in my opinion.

I think one account with different ENV’s and different DEVICES would be more userfriedly.

BTW, i try to register DEV right now and it seems the registration server is broken or offline ? !

:\Users\sebas>matrix register device
 Registering a new device.
Device Registration -- device name Matrix_dev_pi
Device Registration -- device description Matrix Dev Pi
 Device registration request formed...
 Error creating device Matrix_dev_pi:  { Error: Timeout processing worker task -L6rSHnMvTpr40oGmZqY
    at Timeout._onTimeout (C:\Users\sebas\AppData\Roaming\npm\node_modules\matrix-cli\node_modules\matrix-firebase\lib\queue.js:113:21)
    at ontimeout (timers.js:466:11)
    at tryOnTimeout (timers.js:304:5)
    at Timer.listOnTimeout (timers.js:267:5) details: { code: 'TIMEOUT' } }

C:\Users\sebas>matrix register device
 Registering a new device.
Device Registration -- device name matrix_dev_pi
Device Registration -- device description Matrix Dev Pi
 Device registration request formed...
 Registering device...
 Device registration request formed...
 Registering device...

Update
Register worked now, but twice.

But it seems that the app not worked with the DEV ENV.