MATRIX Creator/Voice Hardware Test

ii  libmatrixio-creator-hal:armhf         0.3.7                          armhf        Hardware Abstraction Layer for MATRIX.
ii  libmatrixio-creator-hal-dev           0.3.7                          armhf        Hardware Abstraction Layer for MATRIX (headers)
ii  libswresample-dev:armhf               7:3.2.10-1~deb9u1+rpt2         armhf        FFmpeg library for audio resampling, rematrixing etc. - development files
ii  libswresample2:armhf                  7:3.2.10-1~deb9u1+rpt2         armhf        FFmpeg library for audio resampling, rematrixing etc. - runtime files
ii  matrixio-creator-init                 0.4.12                         armhf        Install scripts that can program the MATRIX Creator FPGA and SAM3 IMU.
ii  matrixio-kernel-modules               0.1.4                          armhf        Install kernel modules for MATRIX devices.
ii  matrixio-openocd                      1.0.1                          armhf        Open on-chip JTAG debug solution for ARM and MIPS systems
ii  matrixio-xc3sprog                     1.1.1                          armhf        Spartan3, XCF and CPLD JTAG programmer and other utilities.

Module                  Size  Used by
fuse                  106496  3
i2c_dev                16384  0
rfcomm                 49152  6
cmac                   16384  1
bnep                   20480  2
hci_uart               36864  1
btbcm                  16384  1 hci_uart
serdev                 20480  1 hci_uart
bluetooth             368640  29 hci_uart,bnep,btbcm,rfcomm
ecdh_generic           28672  1 bluetooth
evdev                  24576  6
joydev                 20480  0
hid_logitech_hidpp     36864  0
spidev                 16384  0
brcmfmac              307200  0
brcmutil               16384  1 brcmfmac
cfg80211              573440  1 brcmfmac
rfkill                 28672  6 bluetooth,cfg80211
i2c_bcm2835            16384  0
spi_bcm2835            16384  0
hid_logitech_dj        20480  0
fixed                  16384  0
uio_pdrv_genirq        16384  0
uio                    20480  1 uio_pdrv_genirq
bcm2835_v4l2           53248  0
v4l2_common            16384  1 bcm2835_v4l2
videobuf2_vmalloc      16384  1 bcm2835_v4l2
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         24576  1 bcm2835_v4l2
videobuf2_core         45056  2 bcm2835_v4l2,videobuf2_v4l2
videodev              184320  4 v4l2_common,videobuf2_core,bcm2835_v4l2,videobuf2_v4l2
media                  32768  1 videodev
snd_soc_wm8960         40960  0
snd_soc_ac108          53248  0
snd_soc_seeed_voicecard    16384  1 snd_soc_ac108
snd_soc_simple_card_utils    16384  1 snd_soc_seeed_voicecard
snd_soc_core          188416  4 snd_soc_seeed_voicecard,snd_soc_simple_card_utils,snd_soc_ac108,snd_soc_wm8960
snd_compress           20480  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_bcm2835            32768  0
snd_pcm                98304  4 snd_pcm_dmaengine,snd_bcm2835,snd_soc_core,snd_soc_wm8960
snd_timer              32768  1 snd_pcm
snd                    69632  6 snd_compress,snd_timer,snd_bcm2835,snd_soc_core,snd_soc_wm8960,snd_pcm
ip_tables              24576  0
x_tables               32768  1 ip_tables
ipv6                  434176  108```


Sorry the first reply was a result from a second Raspberry , i hope it makes sense somewhat… And thanks in advance…



I see the matrixio-kernel-modules installed but in the lsmod output they they dont appear to be running. I also see some modules from seedstudio up, not sure if this can interfere. If its possible my advise is to try from a fresh raspbian sd card using the matrix kernel module as you did. If you can’t do that let us know so we can try to see what could be going on.

Let us know how it goes.

  • Yoel


Let you know as soon as i have some new results.
Regards, Anthony


Ok, first of all thanks for the suggestion, even though i have done this about 6 times so far i had to do it again.
Hope my experience helps others as well.

I setup a new card with Raspian Stretch (Desktop version) and booted up. It did its usual updates and all seemed well, but when i then tried to setup the Matrix Hall as per the website i ran into errors with the installation. I gave up after a few attempts and then began again and setup the card with Raspian Stretch Lite.

When it booted the first thing i did was sudo Raspi-config and enable SSH.

I did not do any updates for Raspian as i feared this may have been the issue only 30 minutes prior.

I logged in via ssh and followed the installation instructions from :-
Then i followed the instructions from :-

To my amazement , i now know for a fact that the hardware is working as the everloop test fuctions properly.
Now i have a fully function rainbow everloop and its back to the drawing board to begin again with something more advanced.

Thanks for your push, i was really getting dismayed but i have a new start.

Regards Anthony.


Glad to help.

Let us know if you need any other help in the future! :smile:



Hello @kevindpatino
I would like to consult you about Hardware test.

Using this hardware test, I check the firmware info in the FPGA.
However, the result came out with “MATRIX device has not been detected
**** Could not program FPGA”.

How can I solve this problem?




I will show the result of the MATRIX Creator/Voice hardware test below.

1.FPGA Test


2.Test your MATRIX board


3.Raspberry Pi GPIO Status.



If there are other necessary information, please point out about it.

Regrads ,



I have the same issue.

Did you have any luck by now?


I wasn’t able to get ODAS to fully functional. I suspect that probably are caused by my hardware issues. I tested all hal examples except GPIO. All of them working properly.

So I tried some steps on Matrix Creator/Trouble shooting, and I encounter several different outputs comparing to the one shown on the page. Are these differences crucial?

First, the raspberry Pi GPIO test, the number of GPIO and in/out hi/lo are different, and may vary after different operations:

gpiochip0: GPIOs 0-53, parent: platform/20200000.gpio, pinctrl-bcm2835:
 gpio-4   (                    |sysfs               ) in  hi
 gpio-16  (                    |sysfs               ) out hi
 gpio-17  (                    |sysfs               ) in  hi
 gpio-18  (                    |sysfs               ) out hi
 gpio-19  (                    |sysfs               ) out hi
 gpio-20  (                    |sysfs               ) out hi
 gpio-21  (                    |sysfs               ) out hi
 gpio-22  (                    |sysfs               ) in  lo
 gpio-23  (                    |sysfs               ) out hi
 gpio-27  (                    |sysfs               ) in  hi
 gpio-47  (                    |led0                ) out lo

gpiochip1: GPIOs 496-511, parent: spi/spi0.0, matrixio-gpio, can sleep:

Second, when I run
sudo /usr/share/matrixlabs/matrixio-devices/matrix-init.bash
I got:

    **** MATRIX Creator FPGA has been programmed!
    INFO: [/dev/matrixio_regmap] was opened
    FPGA IDENTIFY = 5c344e8
    FPGA VERSION = 1000a
    *** MATRIX Creator initial process has been launched
    md5sum: /tmp/em358_dump: No such file or directory
    *** Running the program instead of the bootloader
    Running the program instead of the bootloader
    SAM3 MCU was programmed before. Not programming it again.

Anything would be greatly appreciated.