Matrix creator with alexa

I have installed required dependecies and tested matrix creator is working normal.

But Alexa not taking input from matrix creator.

Is there any additonal changes to do specifically?

Hi @jay7583,

Few questions here:

  • What guide are you following?
  • With “input” you refer to audio from the mics?
  • Have you tried to record some audio first to test the microphones?

Thanks

-Yoel

Hi @yoelrc88 ,

I have followed this link to setup mic.


after that i have tested mic with arecord and audacity,it worked fine
In above question “input” refers to audio from mic.
I have checked when AVS is running ,i started recording in another tab ,it recorded then i understood it is not accessing matrix-creator mic.

Can you share the output of :

sudo dpkg -l | grep matrix
sudo lsmod | grep matrix
sudo cat ~/.asoundrc

Thanks

these are the respective outputs

sudo dpkg -l | grep matrix
ii  libmatrixio-creator-hal:armhf         0.3.2                                armhf        Hardware Abstraction Layer for MATRIX.
ii  libswresample2:armhf                  7:3.2.10-1~deb9u1+rpt1               armhf        FFmpeg library for audio resampling, rematrixing etc. - runtime files
ii  matrixio-creator-init                 0.4.8                                armhf        Install scripts that can program the MATRIX Creator FPGA and SAM3 IMU.
ii  matrixio-kernel-modules               0.1-3                                armhf        Install kernel modules for MATRIX devices.
ii  matrixio-openocd                      1.0.1                                armhf        Open on-chip JTAG debug solution for ARM and MIPS systems
ii  matrixio-xc3sprog                     1.1.1                                armhf        Spartan3, XCF and CPLD JTAG programmer and other utilities.


***********************

sudo lsmod | grep matrix
matrixio_pcm          278528  1
matrixio_codec         16384  1
snd_soc_core          188416  2 matrixio_pcm,matrixio_codec
matrixio_uart          16384  0
matrixio_env           16384  0
matrixio_imu           16384  0
industrialio           73728  2 matrixio_imu,matrixio_env
matrixio_gpio          16384  0
matrixio_everloop      16384  0
matrixio_regmap        61440  0
matrixio_core          16384  4 matrixio_regmap,matrixio_pcm,matrixio_imu,matrixio_env
snd_pcm                98304  5 matrixio_pcm,snd_pcm_dmaengine,snd_bcm2835,snd_soc_core,snd_dummy


******************************

pi@raspberrypi:~/Desktop $ sudo cat ~/.asoundrc
pcm.sc {
type hw
card 2
}
pcm.!default
{
type asym
playback.pcm {
type hw
card 0
device 0
}
capture.pcm {
type hw
card 2
device 0
}
}pi@raspberrypi:~/Desktop $ 


*******************************

So, I understand that you run the Alexa SampleApp like this:
bash ./startsample.sh

and its not detecting your voice when you say “Alexa”?

Also, have you tried to start from the beginning again? I recommend to use this guide instead https://www.hackster.io/matrix-labs/matrix-voice-and-matrix-creator-running-alexa-c-version-9b9d8d. Should pretty much the same but maybe there is something different. I will check later and update the one in github if needed.

Let me know how it goes.
-Yoel

Its not taking mic,Normally when i am running alexa ,if i tried something to record by using arecord it will tell device or resource busy.Here when i tried to record by using arecord,it worked perfectly.
And these step are not different ,those are same.for the record i did already.It gave same result.

Hi,
I tried to change alsamixer settings.i tried to access sound card .

when i selected MATRIXIO SOUND card it gave the error like this

cannot load mixer controls: Input/output error

Is there anything to do with this?

Hi @yoelrc88 ,

In this link

I used preinstalled image its working but if i do those steps in clean image its not doing .
What exactly extra things i have to do in clean image?