MATRIX device has not been detected (Voice and pi3)

I am trying to run the basic everloop through MATRIX HAL on the Matrix Voice and a Raspberry Pi 3B+. Every time I try to run it I receive the “Matrix device has not been detected” error message. I have tried reflashing the pi but it has not worked.

Hi @hopewebb16,

What Raspbian OS and Linux kernel are you using? You can check the OS type with lsb_release -a and the Linux kernel with uname -a in the terminal.

Could you also show the output of the following line?
dkpg -l | grep matrix

This will show a list of which MATRIX packages you have installed and if there were any errors during installation.

Best,
Samreen

Hello, thanks for getting back to me.

When entered lsb_release -a is got the output
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster
and uname -a returned:
Linux raspberrypi 4.19.75-v7+ #1270 SMP Tue Sep 24
18:45:11 BST 2019 armv7l GNU/Linux

dkpg -l | grep matrix returned:

 in  ii  libmatrixio-creator-hal:armhf         0.3.8                             
          armhf        Hardware Abstraction Layer for MATRIX.
      ii  libmatrixio-creator-hal-dev           0.3.8                               
          armhf        Hardware Abstraction Layer for MATRIX (headers)
      ii    libswresample3:armhf                  7:4.1.4- 
           1+rpt1~deb10u1              armhf        FFmpeg library 
     for audio resampling, rematrixing etc. - runtime files
     ii  matrixio-creator-init                 0.4.17                              
        armhf        Install scripts that can program the MATRIX 
    Creator FPGA and SAM3 IMU.
     ii  matrixio-openocd                      1.0.1.002                           
         armhf        Open on-chip JTAG debug solution for 
     ARM and MIPS systems
     ii  matrixio-xc3sprog                     1.1.1.003                           
        armhf        Spartan3, XCF and CPLD JTAG 
        programmer and other utilities.

Hi @hopewebb16,

Please try the steps in this troubleshooting section of the MATRIX Voice and let me know if that resolves your issue.

Best,
Samreen

When I try to flash the SPI flash bootloader I receive this message:

 XC3SPROG (c) 2004-2011 xc3sprog project $Rev: 774 $ 
 OS: Linux
 Free software: If you contribute nothing, expect nothing!
 Feedback on success/failure/enhancement requests:
    http://sourceforge.net/mail/?group_id=170565 
Check Sourceforge for updates:
    http://sourceforge.net/projects/xc3sprog/develop

Cannot find device having IDCODE=1041e03 Revision G

The last line is supposed to read
DNA is 0xf9d61a1ecbb64401

Hi @hopewebb16,

Were you in the /usr/share/matrixlabs/matrixio-devices/ directory when you ran the flashing command?

Best,
Samreen

Can you send a screenshot of your whole command line? What you typed and the error?

I am not currently in that directory.

Can you try the following instead?

cd /usr/share/matrixlabs/matrixio-devices
sudo xc3sprog -c sysfsgpio_voice blob/bscan_spi_s6lx9_ftg256.bit

Let me know the output!

Best,
Samreen

I received a very similar output

Can you share the output of the following?

sudo xc3sprog -j -c sysfsgpio_voice

That is indeed very odd behavior. Can you send a picture of how the MATRIX Voice is connected to the Raspberry Pi and let us know the voltage and amperage on your power supply (should be 5V ~2.5A)?

The voltage should be the correct amount. I purchased the voice, power chord, and pi as a set. Also i don’t know if it helps but it was working as it should a couple days ago and then the next time I turned it on it could not detect the voice device.

I haven’t tested this, but I think carpet could potentially cause electrostatic buildup and result in problems. Can you try picking it up/putting it on a book or something, power cycle, and then run the following in terminal?

sudo xc3sprog -j -c sysfsgpio_voice

Maybe ground it with your hands as well before plugging it back in :sweat_smile:

This was the output. The problem first occurred when it was on a table top. However the last time it was fully functioning it was on carpet.

Hi @hopewebb16,

Is this issue still persisting? If this is the case, let me know and I’ll DM you to work it out.

Best,
Samreen

I switched my raspberry pi and now I get this output. It looks like it at least recognizes the voice?

1 Like

Yes! That is exactly what it should output :smiley:

Maybe install and try a MATRIX HAL example and see if it works now!

Best,
Samreen