Matrix voice audio output NOT WORKING

I found that in 2018, it was written here that the audio output of the matrix voice is not working yet. I tried to use it now and it is still not working. is it true or I am doing something wrong? is there a way to make it work because I need it asap.

THANKS in advance.

Hi @mirame,

Welcome to our community!

The audio output does work now, but currently the MATRIX Voice audio output only works well for a 44100 Hz 16bit stereo output. So, in order to get it working, you would have to install the kernel modules as shown here.

Then, you would use the following command with the specified parameters to record audio using alsa for 5 seconds (adjust -d 5 to change this):

arecord recording.wav -f S16_LE -r 44100 -c 2 --vumeter=stereo -d 5

And the following command to play the audio using alsa:

aplay -D hw:2,1 ./recording.wav

You can check if your MATRIX Voice playback device is card 2, device 1 by typing the following in your terminal
arecord -l

You can also download audio samples from online & play them as referenced in this post.

Let us know if you have further questions!


ok thank you a lot. it works now however it only work with .wav audio files. can it work with .mp3 audio files as well? i tried it with mp3, it did not work, did i forget something or it really does not read mp3 files. thanks a lot anyway.