Matrix Voice ESP32 + Raspberry Pi OS (Mycroft)

Hello everyone,

I have a Matrix Voice ESP32 connected via GPIO to a Raspberry Pi 4, Model B, running the latest Raspberry Pi OS with Mycroft installed. I ran the automatic setup and chose Matrix Voice in the prompts to install the card, but the Voice will not record audio during testing.

I first tried the troubleshooting steps here (which I saved the output from, so if you want the text, just ask - not sure if it’s appropriate to post all of it here initially), then I found the post here to downgrade kernels, and but nothing has worked.

I’m hoping someone here can help troubleshoot. Thank you in advance for your time.

Noticed Matrix currently posted:

:warning: MATRIX Kernel Modules w/ New Raspberry Pi OS Kernel 5.4.79-v7l+

Hi Everyone,

The new Raspberry Pi OS update released in December, 2020 with kernel version 5.4.79-v7l+ is having compatibility issues with the MATRIX kernel modules.

We are working on the fix & will update the community as soon as possible!

In the meantime, you can follow the instructions below for a temporary workaround.

wget http://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-firmware/raspberrypi-kernel_1.20201126-1_armhf.deb

wget http://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-firmware/raspberrypi-kernel-headers_1.20201126-1_armhf.deb

sudo dpkg -i raspberrypi-kernel-headers_1.20201126-1_armhf.deb  raspberrypi-kernel_1.20201126-1_armhf.deb

sudo reboot

sudo apt install matrixio-kernel-modules

sudo reboot

Currently testing. Will update.

The steps above did not result in any noticeable improvement. Still none of the lights on top illuminate when powered on - only the blue light on the bottom of the board next to the identifier “D19” illuminates. Can anyone assist with a solution?