MATRIX Voice ESP32 toolchain in Windows

Hi
according to
ESP setup instruction for MATRIX Voice
https://matrix-io.github.io/matrix-documentation/matrix-voice/esp32/

installation of ESP32 toolchain with Windows PC is not available (yet?):
Windows: https://esp-idf.readthedocs.io/en/latest/get-started/windows-setup.html(currently not functioning)

Is it possible to setup and use M.Voice ESP features with Windows?
is there other/ updated instruction?

Hello @marek1914,

The ESP32 Windows toolchain, while tedious to set up, currently does work! We will be updating the docs, thanks for pointing it out!

Here is a Hackster guide on how to setup over the air programming with ESP32 as well if you’re interested.

Best,
Samreen

1 Like

Thank you!
I was lost and confused a little
now it looks clear.
Best!
Marek

1 Like

Hi!
I see the ESP32 Setup sequence was changed totally! (https://matrix-io.github.io/matrix-documentation/matrix-voice/esp32/)

VSCode+platformio sounds perfect for my so I moved quickly to experiment with it.
… just to be sure, I have installed " PlatformIO IDE for VSCode"
The initial build went smooth at last in the meaning of running LEDs demo.
as you can see at these screens:

and:

But attempts of further deploying, OTA and communication with MV without the RPi failed.

pio run --target upload gave following error

maybe I misuse following instruction:
“To upload using OTA, open a terminal, go into the project directory, and run this command.”
terminal - means GIT bash OK?
project directory - C:\Users\PC\esp32-platformio od C:\Users\PC\esp32-platformio/ota ???

another doubts:
in platformio.ini file
I changed only SSID_GOES_HERE and PASSWORD_GOES_HERE according my local WiFi LAN settings
I didn’t change remaining names as ‘MVESP.local’ , “MVESP”, “voice”, port etc maybe I missed something important here?

all the best!
Marek

Hey @marek1914,

It seems that the hostname is being ignored for some reason. However, you can still upload to your ESP32 device by manually inserting its IP address in the platformio.ini file.

For me, I replaced
upload_port = 'MVESP.local'
with
upload_port = 192.168.2.164

Helpful Network Scanners (Hostname is probably espressif):
IOS App
Android App

Let us know if this resolves your issue!

1 Like

Thank you!
indeed, replacing upload_port with the “static” IP helped

2 Likes