MATRIX Voice on boot yellow LED ring and 1 LED off


#1

Hello Everyone,

You may have noticed that when you turn on your MATRIX Voice for the first time the LEDs turn yellow and then fade in brightness until one LED (D1) is completely turned off. Below is a picture of this:

This default LED state is a remnant of our quality control testing. Once you set up your MATRIX Voice for the first time it will be flashed with the latest software that changes the default LED state to off.

To flash your MATRIX Voice with the latest software run the following commands on the Raspberry Pi that is connected to your MATRIX Voice.

# Add repo and key
curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
# Update and upgrade packages 
sudo apt-get update
sudo apt-get upgrade
# Installation
sudo apt install matrixio-creator-init
# Reboot 
sudo reboot

Please note that the default LED state is what the LED’s of the MATRIX Voice do when you turn it on. It does not affect your ability to program and change the colors/brightness of the LEDs.

If you have any questions please email alfred.gonzalez@matrixlabs.ai

Thanks!


#2

#3

trying different things which appear to be posted by Matrix, i keep ending up with a similar result:

sudo apt-get update
Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Ign:2 http://archive.raspberrypi.org/debian stretch InRelease
Err:3 http://archive.raspberrypi.org/debian stretch Release
503 Service Unavailable [IP: 93.93.128.211 80]
Ign:4 https://apt.matrix.one/raspbian stretch InRelease
Hit:5 https://apt.matrix.one/raspbian stretch Release
Reading package lists… Done
E: The repository ‘http://archive.raspberrypi.org/debian stretch Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
pi@matrixvoice:~ $


#4

nvm, it’s working! exciting!


#5

this is was not working for my
curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -echo “deb https://apt.matrix.one/raspbian $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list

i changed to

wget https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add apt-key.gpg | echo “deb https://apt.matrix.one/raspbian $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list


#6

Thank you @spacemishka, you are right. It should be 2 lines instead of just one:
url https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list

Yoel


#7

Will this code fix the LED problem?
Did you run any code to the Jessie before running this bit of code/
Thanks


#8

as described it is no problem. But after runnung the command mentioned above, the LEDs will turn off.


#9

I ran the code just as displayed (curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -;(2nd line) echo “deb https://apt.matrix.one/raspbian $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list )with a fresh image of Raspbian Jessie, then did sudo apt-get update and sudo apt-get upgrade and reboot. The LEDs are still all on just as displayed in the photo above. Any other suggestions or recommendations?
Thanks


#10

Mmmh Jessie ist outdated. The most recent release is stretch. Have you tried that?


#11

Yes I have done that, and now after changing to a different Pi 3, the lights have turned off. However I still have numerous problems with trying to load and run the Alexa AVS. Are you someone I can question about this or is there someone or someplace I should go to? I have received an email from Alfred Gonzalez-Cuzan and I have not heard back from him.
Thanks


#12

Hey rockman55,

i got it working more or less. Mics performance need to be imporved. If i find some time, i write what i have done. Acutally all tutorials lacking some facts.

regards
Peter


#13

@rockman55

after fresh install of Stretch FULL (not lite). Full has Oracle JDK preinstalled.

sudo apt-get update
sudo apt-get upgrade
sudo reboot

setup node.js

curl -sL https://deb.nodesource.com/setup_7.x | sudo -E bash -;
sudo apt-get install -y nodejs;

setup build tools

sudo apt-get install -y build-essential

Add rep and key

curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo “deb https://apt.matrix.one/raspbian $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list

update & upgrade

sudo apt-get update
sudo apt-get upgrade

install malos package

sudo apt-get install -y libzmq3-dev matrixio-malos matrixio-openocd wiringpi cmake g++ git --force-yes;
sudo reboot

cd Desktop
git clone https://github.com/alexa/alexa-avs-sample-app.git

configure automated_install.sh and run it. run this commands after

cd ~/Desktop/alexa-avs-sample-app/samples
cd companionService && sudo npm start

cd ~/Desktop/alexa-avs-sample-app/samples
cd javaclient && sudo mvn exec:exec

cd ~/Desktop/alexa-avs-sample-app/samples
cd wakeWordAgent/src && ./wakeWordAgent -e sensory


#14

@rockman55,

You can share the issues setting up the Alexa demo here in the community. Better to open a new post on this topic. I can help you out through the process.

Thank you


#15

Thanks for this list, it is different than any other set of instructions I have seen.

I am running this process now, but have come upon an error at the point just after I ran the section Add rep and key

Here is a screen shot:

pi@voice:~ $ curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -

% Total % Received % Xferd Average Speed Time Time Time Current

                             Dload  Upload   Total   Spent    Left  Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 100 2203 100 2203 0 0 5132 0 --:–:-- --:–:-- --:–:-- 5147

OK

pi@voice:~ $ echo “deb https://apt.matrix.one/raspbian $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list

“deb https://apt.matrix.one/raspbian stretch main”

pi@voice:~ $ sudo apt-get update

E: Type ‘“deb’ is not known on line 1 in source list /etc/apt/sources.list.d/matrixlabs.list

E: The list of sources could not be read.

Is this something I can move forward with or is there some other solution.

Thanks

Danny


#16

u need to replace the quote-symbole (“) with ".

Seems a problem with c+p


#17

or do

sudo nano /etc/apt/sources.list.d/matrixlabs.list

delete everthing and paste:
deb https://apt.matrix.one/raspbian stretch main


#18

I found the error in the file /etc/apt/sources.list.d/matrixlabs.list, and changed it just like you mentioned here.I also changed the file /etc/apt/sources.list.d/raspi.list to read:
deb http://archive.raspberrypi.org/debian/ stretch main ui

Uncomment line below then ‘apt-get update’ to enable ‘apt-get source’

deb-src http://archive.raspberrypi.org/debian/ stretch main ui
I uncommented the line that starts with deb-src http://.
I then ran sudo update and sudo upgrade, they both ran to completion. I
I have run the AVS setup and all the commands under the title: configure automated_install.sh and run it. run this commands after.
I can log in to Alexa but I can not get any response from her. I also noticed a set of instructions located at:https://matrix-io.github.io/matrix-documentation/matrix-hal/examples/alexa/.This mentions the asoundrc file and I changed that file per those instructions; still no response. Is there any other changes that need to be made for the mics and speaker to work, or have I missed something?
Thanks again


#19

the problem is u have to get very close to the mics. you can also hit the microphone button you see on your screen instead of saying ‘Alexa’… but mics still not very sensitiv


#20

and you need to delete the asoundrc file. Actually the automated_setup.sh should to it. But if you run it with sudo it tries to delete it from /home/root but it should deleted from /home/pi