Matrix Voice, Snips & Home Assistant working together

Yes, but you should make sure that you first can control your light within Home Assistant.
I mean without any voice control.

The forum for Home Assistant is also very alive, you can find a lot of help there.
After that, you need to add voice control to Home Assistant, i.e. Snips.
The input for the voice control (a.k.a. Microphone) can then be the Matrix Voice or Creator.

So “Just connect this light with Home assistant and matrix” is too simply said.

Thanks for your answer. I’d like followed your full steps.
But after I run sudo apt install matrixio-kernel-modules

It show the error message

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gyp libjs-inherits libjs-node-uuid libuv1-dev lxkeymap node-abbrev node-ansi node-ansi-color-table node-archy node-async
  node-balanced-match node-block-stream node-brace-expansion node-builtin-modules node-combined-stream node-concat-map
  node-cookie-jar node-delayed-stream node-forever-agent node-form-data node-fs.realpath node-fstream node-fstream-ignore
  node-github-url-from-git node-glob node-graceful-fs node-hosted-git-info node-inflight node-inherits node-ini
  node-is-builtin-module node-isexe node-json-stringify-safe node-lockfile node-lru-cache node-mime node-minimatch
  node-mkdirp node-mute-stream node-node-uuid node-nopt node-normalize-package-data node-npmlog node-once node-osenv
  node-path-is-absolute node-pseudomap node-qs node-read node-read-package-json node-request node-retry node-rimraf
  node-semver node-sha node-slide node-spdx-correct node-spdx-expression-parse node-spdx-license-ids node-tar
  node-tunnel-agent node-underscore node-validate-npm-package-license node-which node-wrappy node-yallist python-cairo
  python-gobject python-gobject-2 python-gtk2 python-xklavier
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/16.2 kB of archives.
After this operation, 100 kB of additional disk space will be used.
(Reading database ... 171559 files and directories currently installed.)
Preparing to unpack .../matrixio-kernel-modules_0.1.4_armhf.deb ...
Unpacking matrixio-kernel-modules (0.1.4) ...
dpkg: error processing archive /var/cache/apt/archives/matrixio-kernel-modules_0.1.4_armhf.deb (--unpack):
 unable to make backup link of './boot/overlays/matrixio.dtbo' before installing new version: Operation not permitted
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Do you know the solution?

And I did sudo apt-key adv --keyserver --recv-keys D4F50CDCA10A2849
sudo apt-key adv --keyserver --recv-keys D4F50CDCA10A2849
But it showed gpg: keyserver receive failed: No data

Is there other server?

I do not know, those were working fine before…

I’ve removed DUMMY from matrix-mics.conf ,but why it still show these errors?

Jun 18 13:14:51 raspb snips-audio-server[4332]: ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM bluealsa
Jun 18 13:14:51 raspb snips-audio-server[4332]: ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
Jun 18 13:14:51 raspb snips-audio-server[4332]: ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
Jun 18 13:14:51 raspb snips-audio-server[4332]: ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
Jun 18 13:14:51 raspb snips-audio-server[4332]: ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
Jun 18 13:14:51 raspb snips-audio-server[4332]: connect(2) call to /tmp/jack-115/default/jack_0 failed (err=No such file or directory)
Jun 18 13:14:51 raspb snips-audio-server[4332]: attempt to connect to server failed
Jun 18 13:14:51 raspb snips-audio-server[4332]: INFO:snips_audio_portaudio: Use input device: "default"
Jun 18 13:14:56 raspb snips-audio-server[4332]: ERROR:snips_audio_server   : Source stopped. Bailing out.
Jun 18 13:14:56 raspb systemd[1]: snips-audio-server.service: Main process exited, code=exited, status=1/FAILURE
Jun 18 13:14:56 raspb systemd[1]: snips-audio-server.service: Unit entered failed state.
Jun 18 13:14:56 raspb systemd[1]: snips-audio-server.service: Failed with result 'exit-code'.

Why run " snips-watch” ,it just show

“Watching on localhost:1883 (MQTT)” ,then the cursor stop there and show nothing .

what is your output of arecord -l

snips-watch shows only logs, so when nothing is to be done no lines will be shown

The output of arecord -l

**** List of CAPTURE Hardware Devices ****
card 1: SOUND [MATRIXIO SOUND], device 0: matrixio.mic.0 snd-soc-dummy-dai-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Do we need configure /etc/snips.toml file or just keep original ?

Try sudo apt-key adv --keyserver hkp:// --recv-keys D4F50CDCA10A2849

Microphones from Matrix Voice worked with Snips as long as I did first “apt-get upgrade” on Raspberry. After that update, Matrix Voice did not work any more.

Hi @milode,

Please, take a look to this Hackster post MATRIX Voice and MATRIX Creator Running

Are LEDs working? or is just the mics?
Ultimately you could use this guide - Hardware Test: Microphones , to check for hardware issues.

Let us know the results


Hi @yoelrc88,
thanks a lot for reply.
At the moment I have stopped working with Matrix Voice, because the audio output of Matrix Voice does not work either. I have the impression Matrix Voice isn’t really finished yet.

I am currently trying ReSpeaker 2-Mic/4-Mic/6-Mic Pi HAT from Seeed. The microphones and the audio output work here without problems with snips.

Maybe I’ll try the Matrix Voice again later if it should work stable.
The description on Hackster “MATRIX Voice and MATRIX Creator Running” seems to be very similar to the description of Romkabouter.

Unfortunately I wasted a lot of time with Matrix Voice, in contrast to that ReSpeaker works right away for my purposes.

Hi @milode,

Thanks for the feedback, its always welcomed.

You shouldn’t have any issues with the microphones with Snips, if you have, please post the error and we for sure help you. The output in the kernel modules is currently being worked on due to some bugs, so its not ready yet. We are on that and should be fixed in 1 or 2 weeks max. In the meantime you can use the 3.5mm audio output from the Pi.

Let us know if you need help with the microphones.


Hi Yoel,
thanks for reply.
I’m curious to see if audio output works in two weeks.
if this realy works, I will try Matrix Voice again :wink:

Please include an example app as well!

Except for the fact that the Hackster requires a Pi and mine is esp32 standalone.
Using the Pi works fine, but that is not what I want the device to do :slight_smile:

Hi @milode and others,

The playback is not done yet, still been worked on. Maybe another two weeks, not happy about the last estimated ETA for this. Just wanted to follow up on this and letting you know we are on this.

@Romkabouter, For sure an app will be released as well.


Thnx for the update!

Hi, i am also stopped working with Matrix Voice cause the audio output does not working. Still waiting for this. Hope the output is working soon. I also think about to buy a ReSpeaker.

But perhaps this works after my Holidays in 3 Weeks.


Hi yoel,
now it is mid of November!
What about playing audio out of speaker connecor on Matrix Voice??
it’s really bitter to pay 50USD for a device that can only be used as an LED ring.
You should rename it to “Matrix SILENT”.
Is it possible to get the money back for it?

Hi @milode,

We understand the frustration and are really sorry that this feature has taken some time to be delivered, but as you can see here, we just released last week support for audio output in MATIX Voice. We will be adding this soon to the documentation but if you want you can give it a try today. Please let us know about any issues you have and we will try to help.
Please keep in mind that besides the LEDs you can also use the microphones and the GPIOs on board.

Sorry again about some features not being ready as fast as expected, but you can be sure that we are working on it.

For any other inquiries please email Alfred at He will help you!