Matrixio-kernel-modules broken

@jarvis,

Yup, looks just fine. Not sure then. Other audio except the hotword audio is working? That is odd.

@Samreen

I am also facing issues with snips on the latest raspbian stretch. Since I didnt get it to work, I decided to install an older raspbian image with 4.14. kernel. However, now, I cannot get the matrix voice kernel modules to compile.

I tried to install an older version as advised above however it cannot be found:

pi@snipsbase:~ $ sudo apt install matrixio-kernel-modules=0.1.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '0.1.6' for 'matrixio-kernel-modules' was not found

Trying to install the regular package of course fails (compilation will fail).

What should I do?

Hi @s710,

Welcome to the community!

The downgrade is no longer necessary. We can troubleshoot Snips with Raspbian Stretch on Linux kernel 4.19.

I recommend undoing the downgrade and installing the kernel modules using the steps below.

sudo apt-mark unhold raspberrypi-kernel

sudo apt-mark unhold raspberrypi-kernel-headers

sudo apt purge matrixio-kernel-modules

sudo apt purge raspberrypi-kernel-headers

sudo apt update && sudo apt upgrade

sudo reboot

sudo apt install matrixio-kernel-modules

sudo reboot

Then, type arecord -l and show me the output, along with the output of the mike= line in your /etc/snips.toml file.

If the microphone name is accurate in the snips.toml configuration file, we can continue troubleshooting from there.

Best,
Samreen

I already had a working installation, both mic and speakers working as per arecord recording.wav -f S16_LE -r 16000 -d 5 && aplay recording.wav, however I had issues with snips:

  • TTS playback would randomly stop before end of speech
  • feedback sounds were blocking the audio server, so I had to disable them otherwise snips would not process queries beyond hotword detection
  • it is not possible to record a personal hotword with their script, as it continues to complain about too much background noise, even with a perfectly silent room and a distance to the mic of about 10cm

I thus wanted to get a clean installation with 4.14 to see if that gets the problems solved.

@s710,

The feedback sounds blocking the audio server was an issue I experienced with Snips when the Linux 4.19 kernels had come out. Since then, the issue was solved by Snips, but it is possible it is back or some configuration you have is causing it.

At the time, this Snips workaround helped me solve the issue. I would recommend trying it and let me know what happens.

In the meantime, I will check on how you can install the older MATRIX kernel modules with 4.14 since the command I mentioned before with installing matrixio-kernel-modules=0.1.6 doesn’t seem to work.

Best,
Samreen

Thanks for your feedback :slight_smile: Finally someone who is willing friendly and to help :slight_smile:

Feeling pretty lost with all those snips issues, tho I thought I really should have a standard setup and everything should be straight forward :anguished:

Hi @s710,

I tested Snips with a fresh install of Raspbian Stretch 4.19 using our Snips guide. I had to implement the rate 16000 part of the workaround (the full workaround works too) to get it working since the portaudio issue seems to be back.

Did it work for you?

Regarding the MATRIX kernel module downgrade, if that is still of interest to you, the best way seems to be to compile the older version from source. So, after cloning the repo, checkout the commit of the version you want.

Let us know if you have any questions!

Best,
Samreen