MatrixVoivce Alexa Demo -> range of microfone

Hi,

I set up my Matrix Voice with the Alexa Demo and it is working fine.
I am testing a little bit.

One question, how should the range of the microfone normally be?
I ask because the wakeword is only detected if I am in a range of ~1m
Is this normal or is there something I can optimize?

Hi, I have a similar problem. For me the range is 1-2 m, not more.
So I’m interested for a solution as well.
As per the short movie shown at https://www.hackster.io/matrix-labs/matrix-voice-running-alexa-demo-in-hands-free-mode-404aa3, it should work up to about 10 m (30 feet).

I had the same problem. Created a .asoundrc file in the home directory.
I am now able to record from 10ft away.

EDIT…added min_dB max_dB

After you create the file, reboot or logout-login and do a test recording with
arecord -d 10 --device=mic_channel8 -r 16000 -c 1 -f S16_LE test.wav
…test with aplay test.wav

Then go to alsamixer and you should see the new “MicArray Master” volume option.

/home/pi/.asoundrc

pcm.!default {
type asym
capture.pcm “mic”
playback.pcm “speaker”
}
pcm.mic {
type softvol
min_dB -10.0
max_dB 50.0
slave {
pcm “array”
}
control {
name “MicArray Master”
card 1
}
}
pcm.speaker {
type plug
slave {
pcm “hw:0,0”
}
}
pcm.array {
type plug
slave {
pcm “hw:1,0”
}
}

Worked for me, hope this helps