Mic_channel8: sound is too fast

Hi,

I’m having the problem that all sound recordings on mic_channel8 are too fast.
When I record via:

arecord -q -r 16000 -D mic_channel8 -c 1 -t wav -f S16_LE test.wav

… and then play it:

aplay test.wav

… the sound appears to be faster than actually spoken. It even sounds like a few words where cut off.

I don’t have the problem when I repeat the same with mic_channel0 - mic_channel7.

Anybody else having that problem?
Any ideas how to avoid it?

Hi @tiff,

Can you shared those files so we can see them?

Thanks

Yoel

I exprienced the same kind of problem. When I record with mic_channel0

arecord --device=mic_channel0 -r 16000 -c 1 -f S16_LE test.wav

the first sound is always cut off.

For mic_channel1 it is ok but for mic_channel2, 3 … the same issues.

Can anyone explain what is the role of .asoundrc and how to configure it so the Matrix micros will work. I encountered this file several times in this forum but don’t fully understand. Thanks.


PS: I’ve just bought by creator on April 2017.

I have the same issue, when using the snowy with setting mic_channel8 as main device, my speech have to slow down, then the program able to detect my hotword.

mic_channel0 record speed is normal but the volume is lower than mic_channel8 like whisper.

Hi @H.T.D

That’s new for us. Can you share a recording of all channels using arecord?