Microphone not working


#1

I am trying to run the demos in https://github.com/matrix-io/matrix-creator-hal/tree/master/demos and none of the microphone demo applications work.

Could there be something with my Matrix Creator?


#2

i have mine working. do you have matrix os installed on the pi?


#3

My Setup

Hardware

  • CanaKit Raspberry Pi 3 with 2.5A Micro USB Power Supply
  • SanDisk Extreme 32GB microSDHC UHS-I Card with Adapter
  • Matrix Creator

Downloaded RASPBIAN JESSIE WITH PIXEL from https://www.raspberrypi.org/downloads/raspbian/
Used Etcher (https://etcher.io/) to burn the imaget to 64GB micro sd card
Started Raspberry PI 3


#4

Hi @ronin8600,

Looks good your setup. Just 3 things:

  1. If you are going to use HAL directly please first make sure MALOS service is not runing. They both use the same SPI port to talk to the MATRIX Creator. Try :
    $ sudo killall malos
    and then run the demos in HAL again.
  2. Are you using Jessie with Pixel for a specific reason ?
  3. Have you tried others demos. For example arc_demo, mic_energy or everloop_demo ? Did they work?

Yoel


#5

Tried “sudo killall malos” and verified it was no longer running but the mic_demo still did not work

I am not using Jessie with Pixel for a specific reason. Should I be using something else?

Other Demo Results

  • arc_demo - Appears to work as expected
  • mic_energy - All LEDs are a bright red and do not change intensity
  • everloop_demo - Seems to work as expected ( I see red,blue,green and white lights moving)

When I execute firmware_info I get:
MCU ID = 0x10
MCU version = 0x161026


#6

Can you tri the micarray_recorder demo and convert the output files to wav filles using this guide ?


#7

Records with no errors but I hear no sound during playback

Not sure what I was supposed to do with the alsamixer command

  • It defaulted to the Broadcom Mixer with no capture devices
  • I tried switching to the Dummy Mixer and turning up the volume on all the capture devices

#8

Do you have any other ideas on how to debug this issue?

Has anyone had issues with a defective microphone?


#9

Did you try

arecord --device=mic_channel8 -r 16000 -c 1 -f S16_LE test.wav


#10

Did not work, no sound when I play back the file using aplay


#11

Try with other channels too.
mic_channel0 for example.

Yoel


#12

Same result from other channels.

When I play back the recorded wav I can hear a click at the beginning and end of recorded audio.

I tried running the js examples form the matrix-creator-malos git repo and I get the following repeated many times

Recieved Input Stream: 4000
Found speech block
Recieved Input Stream: 4000
Found speech block

but the resulting output wav has no audio


#13

Please make sure you have MALOS service running and then test
arecord --device=mic_channel0 -r 16000 -c 1 -f S16_LE test.wav

and let us know how did it go.
Yoel


#14

MALOS was running as a service during my tests. I also compiled MALOS myself and ran it manually with the same results.


#15

I also tried running sudo /usr/share/admobilize/matrix-creator/creator-init.bash to see if would help and still had the same result.

Does anyone have any other ideas? Should I get the board replaced?

I have also tried to email creator@matrix.one last week with my problems but I have not received a response? Is there a better contact email?


#16

Ok @ronin8600,
I will email you with the steps to follow.

Thanks for the patience.
Yoel


#17

Hi @ronin8600

If the problem is solved at your side, can you please provide the steps in which you have followed since I am facing a similar problem and my setup is similar to yours but with 16Gb micro SD card


#18

Me to, i need the steps because I just get static noise from this test and none of the matos tests seem to work.

jeff


#19

Hi @Jam1401,

Can you share how is your setup? Also wanted to know what if you are using a MATRIX Creator or a MATRIX Voice board.

Finally if you can share what installation steps did you follow.

Thanks


#20

I actually have both and have the same problem.

I did the setup from https://matrix-io.github.io/matrix-documentation/matrix-os/getting-started/installation/ but when I ran this script
on the PI curl https://raw.githubusercontent.com/matrix-io/matrix-creator-quickstart/master/install.sh | sh things did not go well.

I then downloaded the script and went though it step by step and it looked the issue was the package repo was not pointing at the stretch repo. So went to the community and updated the repos for stretch then things went very well. Everything seemed to work except for the malos microphone tests which did nothing.

I did arecord --device=mic_channel8 -r 16000 -c 1 -f S16_LE test.wav as suggested above and it did at least produce a wav file but it was just noise.

I probably missed something basic in the setup. I should mention I am working at the malos or matrix-os level not the HAL level. But I assume my sound setup is borked in some way.

thanks

Jeff