Microphone not working

Ok @ronin8600,
I will email you with the steps to follow.

Thanks for the patience.

Hi @ronin8600

If the problem is solved at your side, can you please provide the steps in which you have followed since I am facing a similar problem and my setup is similar to yours but with 16Gb micro SD card

Me to, i need the steps because I just get static noise from this test and none of the matos tests seem to work.


Hi @Jam1401,

Can you share how is your setup? Also wanted to know what if you are using a MATRIX Creator or a MATRIX Voice board.

Finally if you can share what installation steps did you follow.


I actually have both and have the same problem.

I did the setup from https://matrix-io.github.io/matrix-documentation/matrix-os/getting-started/installation/ but when I ran this script
on the PI curl https://raw.githubusercontent.com/matrix-io/matrix-creator-quickstart/master/install.sh | sh things did not go well.

I then downloaded the script and went though it step by step and it looked the issue was the package repo was not pointing at the stretch repo. So went to the community and updated the repos for stretch then things went very well. Everything seemed to work except for the malos microphone tests which did nothing.

I did arecord --device=mic_channel8 -r 16000 -c 1 -f S16_LE test.wav as suggested above and it did at least produce a wav file but it was just noise.

I probably missed something basic in the setup. I should mention I am working at the malos or matrix-os level not the HAL level. But I assume my sound setup is borked in some way.



Can you share the output of :
sudo dpkg --list | grep matrix

So I can see what packages you have installed.


Here you go

ii  libmatrixio-creator-hal:armhf     0.2.0                             armhf        Hardware Abstraction Layer for MATRIX.
ii  libmatrixio-malos:armhf           0.1.2                             armhf        Libraries of MATRIX abstraction layer for MOS
ii  libmatrixio-protos:armhf          0.1.1                             armhf        Protocolbuffers for MATRIX abstraction layer
ii  libswresample2:armhf              7:3.2.10-1~deb9u1                 armhf        FFmpeg library for audio resampling, rematrixing etc. - runtime files
ii  matrixio-creator-init             0.4.1                             armhf        Install scripts that can program the MATRIX Creator FPGA and SAM3 IMU.
ii  matrixio-libzwaveip:armhf         0.1.1                             armhf        libzwaveip is a library to control Z-Wave devices from your IP network via a Z/IP Gateway
ii  matrixio-malos                    0.3.0                             armhf        Allows queries to MATRIX Creator hardware via ZMQ.
ii  matrixio-openocd                  1.0.1                             armhf        Open on-chip JTAG debug solution for ARM and MIPS systems
ii  matrixio-protobuf                 3.4.0                             armhf        Protocol Buffers - Google's data interchange format. (From GRPC 3.4.0)
ii  matrixio-xc3sprog                 1.1.1                             armhf        Spartan3, XCF and CPLD JTAG programmer and other utilities.
ii  matrixio-zipgateway               2.61.0                            armhf        zipgateway built using CMake

Did you run
and raised capture and playback volume?

Additionally, please post the content of

Hey @Jam1401 how is it going? Did you solve the recording problem?

Check out this simple video starting guide, here

Please, let me know

Yes I have run alsamixer, the .asoundrc does not exist. But what is strange
is this is the same on Matrix Voice and arecord command works on that
device but on the Matrix Creator I just get static.


I check out that guide and see how I get on. In meetings most of today
sadly but hopefully will get back to it tomorrow.


If there is no ~/.asoundrc, then there should be a

What’s the content of that one?

correct, asound file should be in /etc/asound.conf

Yes I can confirm that exists

Hi @Jam1401

Please purge MALOS (MALOS is a simple wrapper for HAL that exposes data through ZeroMQ):

sudo apt purge matrixio-malos 

I am a little paranoid:


Test with:

How to convert raw files to wav:

Plug the jack audio to the Raspberry Pi (do not connect to the MATRIX Voice jack).

Make sure you have the volume up (you can use the alsamixer)

play wav files with aplay


– afc

Ah Ah some progress

So all channels work fine on the Matrix Creator except for channel 1 and 8 those are very loud static. Which is what I am hearing when I do the arecord command (pre purge). My Matrix voice is exactly the same but the arecord command works perfectly.

Matrix Creator only… all the /tmp/matrix_micarray_channel_1 - 8 have gone since I executed the purge command so arecord actually crashes due to not finding directories. on the Matrix Creator, I did not do purge on the Matrix Voice



After the purge of MALOS the problem with arecord is expected for both Voice and Creator board. MALOS service is the one in charge of creating and updating the mic data files in /tmp/matrix …

Did you try to record audio using the micarray_recorder.cpp demo
on HAL instead of arecord? To do this you can follow steps in matrix-creator-hal repo. That recording should give you 8 files called mic_16000_s16le_channel_#.raw on the folder you run the micarray_recorder demo. To convert and play the final audio files see here. After this step you should get 8 wav files you can play using aplay or simply copy to another computer and play it there.

The idea is to see if the channel 1 keeps outputting that noise.
Please, share the results you get.

Yes I did try micarray_recorder demo on the creator the result was channel 1 and channel 8 were just static, the rest were fine. This is in contrast to the Voice device where all the channels were clear (sorry I made a mistake in my last response). Similarly the creator device outputs static whoosh with arecord and voice device is clear.

Do you want me to put the generated wav files somewhere online?



Would you now think I have a faulty Matrix Creator or at least two bad microphones?

Hello @Jam1401,

As this seems to be a hardware issue with mic 1 I will be sending you a DM so we can discuss the appropriate next steps.

Also, just for clarification. Mic 8 is a virtual beamformed microphone and not a physical microphone. The only physical microphones are mics 0-7. Therefore the noise you are hearing from mic 8 is just coming from mic 1.


1 Like