Microphones not working through Alsa (dummy device?)

Hello.

After getting the matrix-creator software installed, I can not properly access the microphones. Alsa (arecord -l) only lists "Dummy [Dummy] and 8 Dummy PCM decives.

The asoundrc (as seen here: https://gist.github.com/hpsaturn/0605defc0249e7e2ae424b899e02f1d1#file-asoundrc ) seems correct.

Can you tell me what needs to be changed?

Thanks in advance!

Can you confirm if you already have MALOS services install and running?

try:
top | grep malos

Let me know the result.

Yoel

Thanks for your reply! The result is the following line:
557 root 20 0 763616 8928 7256 S 5,3 0,9 0:00.63 malos

Hi @SEckert,

Have you tried record with arecord software?
ex:
arecord --device=mic_channel1 -r 16000 -c 1 -f S16_LE test.wav

You can also try to record using example in HAL repository. You can follow this guide:

https://matrix-io.github.io/matrix-documentation/matrix-hal/components/microphone/

Here we explain how to clone, build, run and also convert the audio files to wav format.

Thanks for your help. I tried arecord, but the result is not only very low in volume, but noisy and distorted.
So, something happens, but maybe there is some other problem.

Can you try to run the ./micarray_recorder demo following this guide ?
https://matrix-io.github.io/matrix-documentation/matrix-hal/components/microphone/

This recording demo records all mics at the same time and converts them to wav audio. This I could see if something is wrong with the mics.

IMPORTANT: before running the example please stop the MALOS service using:
sudo pkill malos
after this malos should not appear listed in the processes . To check the active processes use top.

Let me know if you need any help. :slight_smile: