Power issues with Matrix and Raspberry Pi3

Hello,

I did some testing this morning. I used a new Pi3, a new clean Raspbian image and 3 different power sources.

5.1V 2A resulted in random color LEDs when running everloop_demo – power supply from Adafruit (from last year)
5.25V 2.4A resulted in no LEDs when running everloop_demo – power supply from Adafruit (from last week, same item number as above power supply https://www.adafruit.com/products/1995)
USB cable from laptop, resulted in everloop_demo running correctly.

I did notice that when using the USB cable, the Pi3 would flash a rainbow square in the upper right corner of the screen which apparently means that the Pi3 is running with low voltage.

Matrix recommended using “a low ripple 2A 5V” power supply. I have yet to acquire and test.

Hi @Flynnprgmmr,

Thanks for your feedback, it is very valuable.

To test the sensors, please update depen> dences:

  sudo apt-get update
  sudo apt-get upgrade
  sudo halt
  Turn off/turn on the RPi (I am so sorry)

Update the HAL:

 git pull 
 make #in your build directory

BR,

– Andrés

Hello,
I followed the directions (no need to be sorry about rebooting, all part of the process).
Tried to run the sensors_demo, and nothing but 0’s are returned.
Thanks,
-Brian

Thanks @Flynnprgmmr for the tip. I was having the exact same problem, I have 2 of the matrix-creator boards and was unsuccessful at getting either of them to work. I tried multiple Pi3’s, but no luck. I was not a happy-camper. When I read your post, I thought I would try a different power supply, (was using a 5V 2.5A no-name supply). I think the one I am now using is from Adafruit, it is a 5.25V @ 2.4A supply. I made no changes other than swapping the power supply, and now it’s working!

Thanks for pointing out a variable that I had not considered.

Best Regards

Glad it is working for you, I just received a new shipment of power supplies from Adafruit today 5.25V 2.4A and I get 0 LEDs when running the everloop_demo.
While I don’t see anything to readily identify the individual power supply, could you possibly verify the one that is working for you?
Thanks,
-Brian

First, I’ll be good and answer the question: There is no visible brand name, but on the plug-face it says:

Switching Power Adapter
MODEL: M052240E111
INPUT: 100-240V~
50/60Hz 0.35A
OUTPUT: 5.25V-2400mA
(All the subsequent safety marks…)

Now I apologize in advance, I should have done a LOT more checking before I sent my earlier post. Everything I said was true, I was so happy to plug the new supply in and then run the everloop demo and watch the neopixels spinning around that I responded to the earlier email right away.

However, , after about 5 min of patting myself on the back, I noticed that several of the neopixels began to “flicker” out of sequence. As the minutes ticked by, more and more of them started flickering until all I had was a bunch of randomly flickering lights with no circular running pattern. Totally repeatable, unplug the plug, let it rest for a few min, plug it back in and the everloop runs great, but only for a min or two, and then the random flickering starts up again.

For the heck of it, I hit the Matrix with some circuit cooler spray to no effect. However, when I shot the RPi3, in the vicinity of the power supply with the circuit cooler, the display snapped right back to a nice clean. This most likely means that either the supply quality, (noise or current), degrades as it heats up, or I simply have an poor connection somewhere. Physically

I connected the original supply back on it, just for a test and it still does not work, (just random flickering lights), with or without the cold spray, no difference. But the 2nd supply, DOES cause the everloop to run properly but only for a minute or two before the flickering starts again. In my case I think there 2 issues, the inferior supply and a poor connection somewhere. It looks like I still have a bit more to diagnose.

I just wanted to give you the full story.

PS: Even when the everloop program was running properly, I was still unable to get any of the other demos working.

Well, based on that, I plugged the USB/laptop power back into the Pi3, and ran the everloop_demo, it was good for at least 30 mins, but I had to leave, so I can check Monday to see if it’s still running properly.
Side note, there is no heatsink on the Pi3.

— UPDATE —
As of 9am this morning, the everloop_demo has been running for 4 days off of the USB/Laptop power connection.