Problem Matrix voice + rpi3 + alexa


#1

hello, THX for the work ! GREAT

I’ve put sudo bash /home/pi/startsample.sh & exit 0
in /etc/rc.local
But
it doesn’t seem to work at start. The LED are on (white color)
but wake waord ALEXA doesn’t do anything.
& in the APP on my smartphone my device is OFF LINE

if start it manualy with SSH : bash /home/pi/startsample.sh it’s all ok.
########################################

Alexa is currently idle!

########################################

If i close the SSH Session : Alexa stops & doesn,t work anymore and i get OFF LINE. (:weary:

Another thing : my MATRIX VOICE recognize the wakeword “ALEXA” 1 time out of 10.But it catch every query, no problem for that.
I’ve tried different pronociation of “ALEXA” but no way.

In fact : it all function with SSH start with keyboard . Noway on standalone (:roll_eyes:

An idea
(the language of ALEXA is FRENCH, so as me :slight_smile:

THX, good week end


#2

Hi, the Alexa demo doesn’t come with an option for starting on boot. Please see here (https://github.com/alexa/avs-device-sdk/issues/539) others users possible solutions and common issues.

I would use something like this http://www.diegoacuna.me/how-to-run-a-script-as-a-service-in-raspberry-pi-raspbian-jessie/ rtying to run it as a service. I try it and post here.

Also maybe someone else here in the community have that working using other method :slight_smile:

Let me know if this helped


#3

Hi Philippe,

I have done this before using systemd but I don’t have a working example right now to share. Please check this guide with some ideas https://www.dexterindustries.com/howto/run-a-program-on-your-raspberry-pi-at-startup/.
I am testing and will share once I have it running.
-Yoel