Raspberry Pi Setup Error

Hi all,

Following the installation instructions for setup on my Pi running Raspbian, the command

curl https://raw.githubusercontent.com/matrix-io/matrix-creator-quickstart/master/install.sh | sh

eventually turns out an error of:

node-pre-gyp ERR! Tried to download(404): https://storage.googleapis.com/grpc-precompiled-binaries/node/grpc/v1.1.2/node-v48-linux-arm.tar.gz 
node-pre-gyp ERR! Pre-built binaries not found for grpc@1.1.2 and node@6.7.0 (node-v48 ABI) (falling back to source compile with node-gyp) 

Any help would be much appreciated.

Bryce

Sorry @bryce for the late response on this.

Is this still an issue for you?

Yoel

I have a similar problem during the installation. It is not possible to install grpc.

These are the messages from npm-debug.log:

17358 info lifecycle grpc@1.1.2~install: grpc@1.1.2
17359 verbose lifecycle grpc@1.1.2~install: unsafe-perm in lifecycle false
17360 verbose lifecycle grpc@1.1.2~install: PATH: /usr/local/lib/node_modules/npm/bin/node-gyp-bin:/usr/local/lib/node_module
s/grpc/node_modules/.bin:/usr/local/lib/node_modules/.bin:/usr/local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/s
bin:/bin
17361 verbose lifecycle grpc@1.1.2~install: CWD: /usr/local/lib/node_modules/grpc
17362 silly lifecycle grpc@1.1.2~install: Args: [ '-c', 'node-pre-gyp install --fallback-to-build' ]
17363 silly lifecycle grpc@1.1.2~install: Returned: code: 1  signal: null
17364 info lifecycle grpc@1.1.2~install: Failed to exec install script
17365 verbose unlock done using /root/.npm/_locks/staging-3a08f0df5026584d.lock for /usr/local/lib/node_modules/.staging
17366 silly rollbackFailedOptional Starting
17367 silly rollbackFailedOptional Finishing
17368 silly runTopLevelLifecycles Starting
17369 silly runTopLevelLifecycles Finishing
17370 silly install printInstalled
17371 verbose stack Error: grpc@1.1.2 install: `node-pre-gyp install --fallback-to-build`
17371 verbose stack Exit status 1
17371 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/lifecycle.js:242:16)
17371 verbose stack     at emitTwo (events.js:106:13)
17371 verbose stack     at EventEmitter.emit (events.js:191:7)
17371 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/spawn.js:40:14)
17371 verbose stack     at emitTwo (events.js:106:13)
17371 verbose stack     at ChildProcess.emit (events.js:191:7)
17371 verbose stack     at maybeClose (internal/child_process.js:877:16)
17371 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
17372 verbose pkgid grpc@1.1.2
17373 verbose cwd /home/pi
17374 error Linux 4.4.48-v7+
17375 error argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "grpc"
17376 error node v6.7.0
17377 error npm  v3.10.3
17378 error code ELIFECYCLE
17379 error grpc@1.1.2 install: `node-pre-gyp install --fallback-to-build`
17379 error Exit status 1
17380 error Failed at the grpc@1.1.2 install script 'node-pre-gyp install --fallback-to-build'.
17380 error Make sure you have the latest version of node.js and npm installed.
17380 error If you do, this is most likely a problem with the grpc package,
17380 error not with npm itself.
17380 error Tell the author that this fails on your system:
17380 error     node-pre-gyp install --fallback-to-build
17380 error You can get information on how to open an issue for this project with:
17380 error     npm bugs grpc
17380 error Or if that isn't available, you can get their info via:
17380 error     npm owner ls grpc
17380 error There is likely additional logging output above.
17381 verbose exit [ 1, true ]

Hi mates. I wasn’t able to solve this one manually. I was having some other unrelated issues, so I ended up trying a fresh install on a different SD card,

The God of Mysterious Unsolvable Computer Errors then chose to leave me alone for the most part.

Good to hear it. Sometimes that’s all you can do, is start anew.