Read a sound Crash my raspberry

Good morning, ladies and gentlemen,

I haven’t posted on this forum for a long time but I have a problem that I can’t solve.

I have a 3b+ rpi with Buster and a Matrix Voice.

When I do with ssh :

`aplay my_song.wav`

I obtain :

`-bash: /usr/bin/aplay: Input/output error`

and my raspberry crash :

`sudo`        ->   `-bash: /usr/bin/sudo: Input/output error`

or :

`aplay -l`    ->   `-bash: /usr/bin/aplay: Input/output error`

Please, if someone could help me.
Thanks in advance.

This problem exist since I downgrade my linux kernel modules as explain here on this forum .

Maybe someone could tell me how to do the reverse action.

Thanks in advance.

I had try to update kernel…
now I have :

pi@raspberrypi:~ $ sudo apt install matrixio-kernel-modules
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
matrixio-kernel-modules
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/20.9 kB of archives.
After this operation, 115 kB of additional disk space will be used.
Selecting previously unselected package matrixio-kernel-modules.
(Reading database … 96015 files and directories currently installed.)
Preparing to unpack …/matrixio-kernel-modules_0.2.5_all.deb …
Unpacking matrixio-kernel-modules (0.2.5) …
Setting up matrixio-kernel-modules (0.2.5) …
Loading new matrixio-kernel-modules-0.2.5 DKMS files…
It is likely that 5.4.79-v7+ belongs to a chroot’s host
Building for 5.15.56+, 5.15.56-v7+, 5.15.56-v7l+, 5.15.56-v8+, 5.4.79+, 5.4.79-v7+, 5.4.79-v7l+ and 5.4.79-v8+
Module build for kernel 5.15.56+ was skipped since the
kernel headers for this kernel does not seem to be installed.
Module build for kernel 5.15.56-v7+ was skipped since the
kernel headers for this kernel does not seem to be installed.
Module build for kernel 5.15.56-v7l+ was skipped since the
kernel headers for this kernel does not seem to be installed.
Module build for kernel 5.15.56-v8+ was skipped since the
kernel headers for this kernel does not seem to be installed.
Building initial module for 5.4.79+
Error! Bad return status for module build on kernel: 5.4.79+ (armv7l)
Consult /var/lib/dkms/matrixio-kernel-modules/0.2.5/build/make.log for more information.
dpkg: error processing package matrixio-kernel-modules (–configure):
installed matrixio-kernel-modules package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
matrixio-kernel-modules
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $

Please help me. Thanks.