Recorded Microphone audio stream is Silent in Channel 0

Hi,
Please help me with the below issue,
I am using Matrix Creator along with Raspi3 [Jessie Pixel]

When i was trying to run the Microphone test recorder , i was getting 8 Audio streams as RAW and after converting them to WAC when i tried to play the Channel 0 Audio track using aplay it was total Silent.

All the other wav tracks were having noises like “GRRR” . Am i missing something here ?

Is there any steps i need to do with ALSA Mixer ?
Should i need to replace any file configurations in Raspbian to map the Microphones…
I really think that the Documentation can be little improved and i will also be happy to contribute on the Documentation if i was able to success fully run this sample.

I have uploaded the audio tracks
https://github.com/matrix-io/matrix-creator-hal/files/1011919/audiosamples.zip
and ARECORD test clip,
https://github.com/matrix-io/matrix-creator-hal/files/1016325/test.zip

Kindly help me, thanks

Regards
JK

Hi @JK001,

I was reading the issue in Github and also downloaded and listen to the audio files. It looks like a hardware issue but all mics with problems is really weird. One dumb question, have your tried a fresh start flashing your SD card again? The answer is probably yes at this point but is always worth asking.
Also, can you try to do the same recordgin using as a source of sound 1Khz sound ? You can use your phone’s speaker. Just put the phone close the Creators while recording. Please share the audio and raw files too.

Waiting for the files …

Yoel

Hi @JK001,

Do you have any results?

Hi Yoel,
thanks for the reply…it looks like an hardware issue with my Matrix Boards microphone and i have confirmed it with another Matrix board from my friend which works fine for the same env…

Any how i will test that 1 KHZ file and upload you the audio tracks for further investigations…

Thanks a lot for helping out…

Regards
JK