Reset doesn't work

Hello,

I started with an matrix voice today and I’m not able to reset the ESP32 flash memory.

pi@raspberrypi:~ $ sudo voice_esp32_enable
pi@raspberrypi:~ $ esptool.py --chip esp32 --port /dev/ttyS0 --baud 115200 --before default_reset --after hard_reset erase_flash
esptool.py v3.1
Serial port /dev/ttyS0
Connecting...
Failed to get PID of a device on /dev/ttyS0, using standard reset sequence.
....._____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to ESP32: Invalid head of packet (0x00)

I checked the fpga_info and I think it looks ok.

pi@raspberrypi:~ $ /usr/share/matrixlabs/matrixio-devices/fpga_info
INFO: [/dev/spidev0.0] was opened
FPGA IDENTIFY = 6032bad2
FPGA VERSION = 1000b

When I tried to install the first demo with the lights it’s the same:

tar: firmware.bin: time stamp 2021-10-06 22:38:54 is 3.443250721 s in the future
-----------------------------------
esptool.py wrapper for MATRIX Voice
-----------------------------------
esptool.py v3.1
Serial port /dev/ttyS0
Connecting...
Failed to get PID of a device on /dev/ttyS0, using standard reset sequence.
....._____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to ESP32: Invalid head of packet (0x00)
done

[SUCCESS] Please disconnect your MatrixVoice from the RaspberryPi and reconnect it alone for future OTA updates.

Do you have any idea what I’m doing wrong?

Best regards,

William