Rhasspy on RPi 3B+ with Matrix Voice

Hello Matrix-Community,

because of Snips being sold to Sonos, I paused my work on building my own offline voice assistant.
Now, that I want to aim at this goal again, I would like to go with Rhasspy.

I found the hackster guide of @Carlos and @Samreen and saw that they are livestreaming episodes on Rhasspy now, which is absolutely great for me as a non-programmer.

the situation:
I was able to follow the guide till the end. The only thing I changed is setting the profile to “de”, so the command to start Rhasspy was:

docker run -d -p 12101:12101 \
  --restart unless-stopped \
  -v "$HOME/.config/rhasspy/profiles:/profiles" \
  --device /dev/snd:/dev/snd \
  synesthesiam/rhasspy-server:latest \
  --user-profiles /profiles \
  --profile de

btw: Rhasspy now has pocketshinx as default wake word engine

the problem:
Rhasspy does neither react on the default porcupine wake word “Porcupine” nor on the german translation “Stachelschwein”. The Log stays empty.

what I tried:

  • I restartet the Pi and Rhasspy several times and rechecked the settings.

  • I checked if the Matrix Voice is working as mircophone with the standard test:

      arecord recording.wav -f S16_LE -r 16000 -d 5
      aplay recording.wav
  • I went to “Speech” in the web interface and used “Hold to record” for a test. Some logs appeared showing things I might have said (recognition was not that good btw).

  • I went to “Log”, cleared it and used “Wake” in the top right corner. Some logs appeared showing things I might have said (recognition was not that good again)

If anyone has an idea on what to try next or what to do to solve the problem, please help me with this.

Best wishes

Why not ask your question here: https://community.rhasspy.org/ :slight_smile:


Thank you for the hint @Romkabouter. I am new to Rhasspy and did not know the community. Because of @Carlos and @Samreen making videos on it, I thought it might be a good choice to ask here. I will post my question for the Rhasspy community, too.