Sam test Microphone is working but "hey snips" doesnt

sam test Microphone is working but “hey snips” doesnt work.
sam watch just says “Watching on localost:1883 (MQTT)”.
Snips doesnt understand “hey snips”.

Hi @LouisK,

Welcome to the community!

This usually happens when the /etc/snips.toml file doesn’t have the correct microphone config. sam test microphone works because that uses the default /etc/asound.conf config instead.

Can you show me the output of the following commands?

  • arecord -l
  • the mike= line you input into the /etc/snips.toml file

Depending on your version of the MATRIX kernel modules, the MATRIX microphone name might be a tiny bit different which could be causing this issue.


Hi Samreen,
I had kernel model 4.19 so i tryed doing this
Kernel Modules 4.19 Workaround but now nothing is working anymore because i cant install the Matrix kernel and im getting the same problem as Michael (from the link above)

Hi @LouisK,

You don’t need the workaround anymore as we updated our kernel modules to work with Raspbian 4.19.

You can undo the workaround by pasting the following lines one by one:

sudo apt-mark unhold raspberrypi-kernel

sudo apt-mark unhold raspberrypi-kernel-headers

sudo apt purge matrixio-kernel-modules

sudo apt purge raspberrypi-kernel-headers

sudo apt update && sudo apt upgrade

sudo reboot

sudo apt install matrixio-kernel-modules

sudo reboot

The reason it may not be working for Michael is because he didn’t run the following lines first before installing the MATRIX kernel modules. These lines allow the MATRIX packages to be recognized.

curl | sudo apt-key add -
echo "deb $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
sudo apt update
sudo apt upgrade

Edit: I noticed that the quotation marks in the commands in my post were being turned into special characters as I hadn’t put them in a code block. That tiny issue was causing commands not to run as they should. If you try the above, you should be able to install the MATRIX kernel modules without issue now.

1 Like

Thanks Samreen :grinning: ,
I will try it out and give you an ubdate later :+1:

Hi @Samreen,
I reinstalled everything on a fresh installed Raspbian but im facing the same problem,
“Sam test microphone” works just fine but “sam watch” only gives me “Watching on localhost:1883 (MQTT)”.
Sam status:
OS version … Raspbian GNU/Linux 9 (stretch)
Installed assistant … Computer
Language … de
Hotword … hey_snips
ASR engine … snips
Status … Live

Service status:

snips-analytics … (not running)
snips-asr … 0.63.2 (running)
snips-audio-server … 0.63.2 (running)
snips-dialogue … 0.63.2 (running)
snips-hotword … 0.63.2 (running)
snips-nlu … 0.63.2 (running)
snips-skill-server … 0.63.2 (running)
snips-tts … 0.63.2 (running)

Hello @LouisK ,
step by step…

If you can do screenshots for :

  1. « sam service log »,
  2. « sam setup audio »,
  3. « sudo nano /etc/snips.toml » the line begining by mike = … ,
  4. « sudo nano /etc/asound.conf »,
  5. « aplay -L » and « arecord -L ».

Like that, it will be more easy to help you.

Thank you,

1 Like

Hi @Tengu,
thanks for the help,

conf snips_audio_server


Could you also send us the output of lsb_release -a?

If your OS is Raspban Buster, then the above is not likely to work since it came out only 4 days ago, and we haven’t built out support for it yet!

If that is the case, for now, you can install our kit image with Raspbian Stretch Desktop and Snips stuff should work!


EDIT: I just realized your posts says Raspbian Stretch so this wouldn’t apply to you!


I think I see your issue!

In your /etc/snips.toml file, please remove the “#” sign next to mike = "MATRIXIO-SOUND...", that means the line is commented, and it needs to be uncommented to work!


1 Like

Yes, im using Raspbian Stretch :+1:

1 Like

Thank you so much that was it :grin:

1 Like

LOL, :smiley::smiley::smiley: without « # », it will work better !

Have a nice day !

1 Like

Hi guys thank you so much for your help but i ran into new problems with the audio and i made a new thread for that could you please look into that?

having a similar problem. sam test speaker works an also sam test microphone gives me back my speech. However, if I call “Hey snips” there is no reaction.

My config:
Linux raspberrypi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux


  • output to RP USB
  • input via MATRIX VOICE (ESP32 unused)

What is wrong here? Any help / hint would be appreciated.


Hey @df1gr,

Were you able to solve the issue?

Generally, these are things to look at for Snips troubleshooting:

  • Check you have Raspbian Stretch 4.19
  • Type arecord -l and ensure the card & device number match the numbers in the mike="MATRIXIO-SOUND: - (hw:2,0)" line in /etc/snips.toml file
  • If when doing sam watch from your PC, you find it is getting hung up on the audio playback from Snips, try the fix from here. I would recommend first trying only the rate 16000 part and checking if it works as it may be enough!


Hi Samten,

yes, I made the mistake.

In /etc/snips.toml setup mike="MATRIXIO-SOUND: - (hw:2,0)“.

However, in my RP it sets the the Matrix-Sound on (hw:3, 0).

If I have corrected this to mike="MATRIXIO-SOUND: - (hw:3,0)“ and it works as expected.

But, I bought Matrix Voice (ESP32) to use it independently from RP.

Unfortunately, this worked with the OTA program


only sporadicly and with noice and broken audio output. It seems, that the ESP32 doesn’t support audio with 16000 samples unsatisfactory.

Do you support ESP32 with a program which works with similar good audio as Matrix is connected direct to RP?



Hi Roland,

We wrote a Hackster guide based on Rom’s MQTT Audio Streamer to be set up using PlatformIO so you can edit in Visual Studio Code if you want to take a look.

From my experience, Snips works very well with Rom’s code in terms of detecting voice commands. The audio playback is a bit buggy, but this can be improved through software updates. We will be looking into that more going forward and Rom has improved the audio over time as well. This is the function that you could edit to improve it if you would like.

For now, this is the best we have seen for a standalone ESP32 MATRIX Voice sending & receiving from Snips.