Setting up a Matrix Voice on a Raspberry Pi 4B

Hello guys! I am very new to both Raspberry Pi and the MATRIX board but I wish to make use of the ODAS setup to perform sound source localization on my project. However, when I am trying the tutorial from this link, I failed on the initial setup as it stated
gpg: no valid OpenPGP data found.
when I tried the curl step.

And if I tried to ignore it, I got the issue that

Unable to locate package matrixio-creator-init

when I try to

sudo apt install matrixio-creator-init

I have tried various solution suggested on the threads like downgrading the Kernel but it just doesnt work…

Could I seek help or maybe a possible solution here… I got stucked here… Thank you.

1 Like

Same issue. Please let me know if you found a solution

Thanks

Heyy EngineerDream, I have found a solution which is by using the raspbian buster version instead of the latest version, the procedures then went good.

Hello!,

I am using Raspbian Buster (10) and I have the same issue. I got stucked here.

Thanks!

@Juan I remember when I eventually solved it I am using rasbian Buster and follow Christian’s suggestion under this post - it seems that the link provided is dead and needs to use this one. You may try to see if it works!

Can’t install MATRIX HAL - General Discussion - MATRIX

Thanks. Yes, with Buster version I got it working. Thanks