[Solved] Can not flash demo to Matrix Voice with ESP32 ... address must be a number error


#1

Hi, i am trying to load the everloop demo to my matrix voice but I always get an error.

**************************************************************
Programming the ESP32 in MATRIX Voice through the Raspberry PI
**************************************************************
pi@192.168.0.150's password: 
-----------------------------------
esptool.py wrapper for MATRIX Voice
-----------------------------------
usage: esptool write_flash [-h] [--flash_freq {keep,40m,26m,20m,80m}]
                           [--flash_mode {keep,qio,qout,dio,dout}]
                           [--flash_size FLASH_SIZE]
                           [--spi-connection SPI_CONNECTION] [--no-progress]
                           [--verify] [--compress | --no-compress]
                           <address> <filename> [<address> <filename> ...]
esptool write_flash: error: argument <address> <filename>: Address "/tmp/build/everloop_demo.bin" must be a number

I have done all the steps from: https://github.com/matrix-io/matrixio_hal_esp32
Everything worked fine expect the last step where I should flash the Matrix Voice.

Can someone please help me with that.
I am really frustrated about that and I slowly start disliking this product because I can’t even get a basic example running.

Thanks in advance for your help.


Matrix Voice ESP32: problem with Build and Make
#2

Are you using a Windows or a Linux PC for the esp-idf installation?


#3

I am using Mac OS.
I already tried Windows which failed totally.
I can try in a virtual machine with linux, but I would prefer Mac OS


#4

Is the first time I see this error. I found this issue in the esptool tool. Unfortunately, the answer doesn’t seem to help here in your case. I normally using a Linux PC, but will try to replicate with Mac OS.


#5

OK so i am going to try it with Linux also.

I installed Matrix OS in the mean time.
Is it also possible to install the Matrix OS directly on the ESP32 or do I need a raspberry pi for it?


#6

OK let me know.

For the MATRIX OS you need the Raspberry Pi.


#7

Alright.
Thank you :slight_smile:


#8

One more question…

What can I do when I start the HelloWorld Example on Matrix OS.
But no LED flashes?


#9

The Matrix has a Blue LED at the bottom on!


#10

Could be multiple things :slight_smile: . My suggestion is to open a new post so we can follow up on that on a defferent conversation.

-Yoel


#11

@hpposch,

I found how to fix it. See the change required is here https://github.com/matrix-io/matrixio_hal_esp32/pull/7/files

When we this is merged you can just use git pull but for know you manually tried it.

Let me know if it works for you.


#12

Great, thank you :slight_smile:

I am going to try this.
Did you test it on Mac or Linux?


#13

I face the same issue on linux and your fix works!

For the moment I will stay with linux.

Thank you for your help :slight_smile:


#14

Hi,

It doesn’t work on me either.
fix in deploy makefile unfortunately did not help.

anybody has another idea ?


#15

How to solve on mac? I have a same problem on mac!

`esptool write_flash: error: argument <address> <filename>: Address "/tmp/build/ota_data_initial.bin" must be a number`

#16

Hi,
I tried the mac.