[Solved] Cannot Connect to Matrix Voice

After running through these installation instructions (and receiving no errors), I cannot talk to my MATRIX Voice device. matrix ping doesn’t return any results or pulse the device’s LED ring. I cannot install any apps, an error message says it cannot reach the device.

According to the Pairing Instructions, they say: “2. Turn on your MATRIX+Pi (lights should pulse blue after a minute if MOS is running properly)”. But the lights are not blue or pulsing. Actually, they’re a faint green. Also, each LED along the ring appear to fade in brightness, as if there is not enough power even though I’m using an adequate power supply.

I’m assuming that MOS is not installed properly on the device? Is there anyway to re-flash the device with the factory install?

My Setup:

  • MATRIX Voice (ESP32 version)
  • Raspberry Pi 3 B+
  • 5W 10 Amp power supply (plugged into the Pi’s micro USB port)


Hi @jason,

After the installation you followed you should have MALOS services running after boot. Can you check if it is running ?
You can use top -n 1 | grep malos .

Let me know the result.



MOS runs in the Raspberry Pi and talks to the MATRIX Voice board using the software layer called MALOS. You should have MALOS running if all setup went through without problems, but MOS you need to run it using the instructions :

Can you confirm you did go through these steps too?


Here are the results. That command appeared to return nothing.

I did register device adding its ID and Secret per those instructions.

1 Like

When I run node index.js on my Pi, I see the message “MALOS Unavailable” in the output:

Is there a separate link with MALOS installation\startup instructions?

In an attempt to try to install MALOS, I’ve done the following but received errors:

sudo apt-get update

sudo apt-get install matrixio-malos

OK, I appear to be up and running! The trick was getting MALOS installed. I think the missing link, which I didn’t find anywhere in any of the docs (I could have over looked it), was to run the following sequence:

curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
sudo apt-get update
sudo apt-get upgrade
sudo apt install matrixio-malos

Once I ran curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -, the errors that I received (listed above) went away and now I’m able to identify and interact with my MATRIX Voice device.

I’ll mark this as solved. Thanks!

1 Like

Great , glad to hear that !

I had the same problem and your solution solved it. Thank you. Should not that be added to the official documentation?