[SOLVED] Cannot get an app to run

I seem to have many problems as I begin using this product. Fist as encouraged to not use sudo a lot of times things do not work without having to use sudo when I use the matrix cli commands. I have managed to have a initial setup done on;ly with the version 5.5 of Matrix OS.

So I created an app by the name myTest. on the app.js file I put the following that I got from the documentation:

matrix.led({
// number of lights to use [ 90° = 9 ]
arc: 9,

color: ‘green’,

// index to start drawing arc
start: 12
});

//no color assumes off
matrix.led({
arc: 360
})

// draw a point
matrix.led({
angle: 245,
color: ‘white’,
// blends interlight space if true, solid lights if false, default false
blend: true
})

// support multiple shapes

when I deploy the app it gets deploy, able to start and stop but no led lights show up

Any help to go forward would be highly appretiated.

Manoj,

Thanks for writing. We have updated the everloop documentation to be more current.

That error is strange. You shouldn’t have been able to deploy an invalid configuration.

Can you paste your config.yaml?

Also, new versions of matrix-os and the CLI are available. Please pull the latest.

Thanks,
Sean

Hi Sean, first the latest build was not working for me… I was running into errors when I tried to have the Matrix OS up that is the version 5.8, version 5.5 is what worked when I start the OS, and I can view responses happening I I work on the client. The error screenshot is from the OS. Below is the config.yaml file which I have not done any change since its generation.

do not touch this line

configVersion: 2

description: testing app
keywords: ‘led’

Also, I see no change as of yet in the everloop documentation

We changed the option for arc to be in degrees, not number of lights.

Looks like we have a bug in the app creation process.

What you can do in the meantime is add the following to config.yaml

name: led

Re deploy and it should pass validation.

I’ve published 1.2.3 of the CLI. It has a fix for create so it includes the name in the config.yaml.

Please do matrix create ... again and the config should be correct this time.

Thanks!
Sean

Sean,
Ok here is the deal now.

  1. Updated to the latest cli build.
  2. created a new app (newApp) and added the following lines/line to app.js

matrix.led([0, 0, 0, 0, ‘yellow’, 0,
0, 0, 0, 0, 0, 0, 0, ‘yellow’, 0, 0,
0, 0, 0, 0, 0, 0, ‘yellow’, ‘yellow’,
‘yellow’, ‘yellow’, ‘yellow’, ‘yellow’,
‘yellow’, ‘yellow’, ‘yellow’ ]);

  1. Went ahead and deployed and ran, on matrix-os the following lines show up:

newApp 1.0.0 installed from https://storage.googleapis.com/admobilize-matrix-apps/apps/newApp/57fe3bfb8333f31f00784211/newapp-6995177.zip
firebase config valid, but not validated, check flow
==== Application newApp started! ====

Guess what … no led’s turn on … Either I am doing something wrong or something is wrong… I really need to see something work on this device.

You need to include the .render() at the end of the matrix.led chain to write the lights to the LED.