[SOLVED] Connectivity problems

Dear Community,

I got my MC using PI3 and Raspbian Jessie Lite. Following the instruction here:

and here

I am able to install all the components needed and the HAL. However once I try to run MALOS I got the following message (previously SPI has been enabled via raspi-config):

$ malos


MALOS starting


can’t open device
You can query specific driver info using port 20012.
terminate called after throwing an instance of ‘zmq::error_t’
what(): Address already in use
Aborted

and for the demos this one:

can’t sentd spi message.

Thank you for sharing!
Vito

I am having the same issue but only on raspberry pi 3, on Raspberry Pi 2 everything works fine.

Actually I found out that everything works fine even on RPi3 if I run as default user “pi” but if I create a new account I also get the same “can’t sent spi message” message. I hope this helps

Hi Leonardo,

thank you for sharing. Actually it does work with the pi user. I will use it.

Thank you,
Vito.

Since recent update we don’t need anymore to do $ malos on another window terminal. It run as a service