[SOLVED] D48 flash very fast, and could not run "everloop_demo"

Hello, after I insert MATRIX Creator into RPi 3 B, the D48 flash very fast

And I could not run “everloop_demo” after I setup SPI (according this page https://matrix-io.github.io/matrix-documentation/matrix-hal/components/SPI/) and build “matrix-creator-hal” project.

The “D48” is located in the red circle of this picture:

Hi @rhzhan,
Can you share what installation steps did you follow ?
Are you trying to use the MATRIX Creator from the MATRIX OS (node JS) or from C++ just using HAL ?

Thanks,

Yoel

Hello @yoelrc88,

Thanks for your reply :slight_smile: I was just trying to use MATRIX HAL following https://matrix-io.github.io/matrix-documentation/setup/ and https://github.com/matrix-io/matrix-creator-hal/blob/master/README.md

Thank you so much :slight_smile:
rhzhan

So were you able to run the examples using HAL ?

sorry maybe I can’t catch your point… I tried to run “everloop_demo” via ssh after I build the HAL project.

Anybody know how to fix it? :disappointed_relieved:

Hi @rhzhan,

Can you share you installation steps? It looks like the FPGA hasn’t been programmed. You can setup that installing matrix-creator-init

sudo echo “deb http://packages.matrix.one/matrix-creator/ ./” | sudo tee --append /etc/apt/sources.list;
sudo apt-get update;
sudo apt-get upgrade;
sudo apt-get install cmake g++ git libzmq3-dev wiringpi xc3sprog matrix-creator-openocd
sudo apt-get install matrix-creator-init

After matrix-creator-init is installed, each time you boot the Pi the FPGA will be programmed and ready for use.

Yoel

Thanks for your replying… I was just following “Install from source” in https://github.com/matrix-io/matrix-creator-hal/blob/master/README.md

BTW, when I was following your guide, RPi3 told me that

The following packages have unmet dependencies:
matrix-creator-openocd : Depends: libjim0.75 (>= 0.73) but it is not installable

:frowning:

Finally, I configure, make and install https://github.com/matrix-io/matrix-creator-openocd , https://github.com/matrix-io/xc3sprog , https://github.com/matrix-io/matrix-creator-init and https://github.com/matrix-io/matrix-creator-hal

HAL’s demo would be worked after running creator-init.bash …

Thank you guys, you’re so appreciated … I could not fix this issue only with the official documents!